L2A_Process requires Intel MKL?


I am trying out L2A_Process [on Ubuntu 14.04] with the test data from:


30 seconds into the process, it crashes with this message:

Progress[%]: 31.05 : Intel MKL FATAL ERROR: Cannot load libmkl_avx.so or libmkl_def.so.

Both .so are in /home/user/anaconda2/lib which I have put in LD_LIBRARY_PATH.
(I have also created symbolic links from /usr/lib to these 2 libraries as an alternative).

On the web, this problem links to Intel MKL acceleration of numpy and scipy routines. Is there a way to get rid of this dependency, and run numpy/scipy in non-accelarated mode? Any other way to get around this.


PS: The machine is an Intel® Xeon® CPU E5-2680 v2 @ 2.80GHz

Did anyone succeed in running this sen2cor software on Ubuntu 14.04 (or better)??

I tried another box and run into exactly the same problem. There is actually another, earlier, issue with a missing /usr/lib/x86_64-linux-gnu/libcom_err.so.3 which can be circumvented with a symbolic link, but suggesting this stuff was never tested on Ubuntu.

I installed exactly as prescribed in the SETUP.pdf. When I do (in anaconda python):

import numpy as np

I get the following:

libraries = [‘openblas’]
library_dirs = [’/home/lemoigu/anaconda2/lib’]
define_macros = [(‘HAVE_CBLAS’, None)]
language = c
libraries = [‘openblas’]
library_dirs = [’/home/lemoigu/anaconda2/lib’]
define_macros = [(‘HAVE_CBLAS’, None)]
language = c
libraries = [‘openblas’]
library_dirs = [’/home/lemoigu/anaconda2/lib’]
define_macros = [(‘HAVE_CBLAS’, None)]
language = c
libraries = [‘openblas’]
library_dirs = [’/home/lemoigu/anaconda2/lib’]
define_macros = [(‘HAVE_CBLAS’, None)]
language = c

Which apparently links to the crash message (same as before).

I can’t remember to have had issues with “open sores” packages like these before.

PS. This box is an Intel® Xeon® CPU E5-2620 v2 @ 2.10GHz

Hi glemoine,

I tried sen2cor on two Intel® Xeon® CPU E5-1620 0 @ 3.60GHz desktop computers on Debian 8 and I got pretty similar issues.

But the following workaround seems just fine on both computer.

  1. I used conda to uninstall numpy and its fellow packages (removed like 20 different packages) and it downgraded even gdal to 1.10.1.
  2. I reinstalled numpy using conda. It only installed numpy from the above mentioned list.
  3. I tried to run L2A_Process and it kept complaining about the missing packages in the first minute of running.
  4. At first pytables,
  5. scipy,
  6. matplotlib and
  7. glymur
    So I installed these using conda. Now It runs without a problem producing valid outputs.