Land Sea Mask writes a black .dim image when cropped with a vector file

I need to preprocess and crop a Sentinel-1 image using a predefined shape file.

For this purpose I am using the Land-Sea-Mask operator and the Graph Processing Tool function, because I will be processing long time series of data.

The processing seems to work correctly, all steps are executed and a target product is saved as .dim file (it will be necessary to save the data as .dim products).

When I open the .dim file in SNAP I get a black image. When I move the cursor I see that the pixel info is stored and supposedly correct dB pixel values are shown.

I can also export the mask pixels as .csv file and I get for each Lat and Long the unique Sigma0_VV_db and Sigma0_VH_db intensities, so I assume the preprocessing worked out correctly.

Any idea how I can also visualize the .dim data and what the problem might be?

Thanks in advance,

I guess it is a problem with the contrast stretch. Go to the Colour Manipulation Window.
Select the slider view and the click on one of 2-sigma, 3-sigma or 100%.

This unfortunately doesn’t help, because in the color manipulation I don’t see the full range of values. It is at min / max -15.766 and cannot be updated.

And what happens when you zoom in or click on ‘Rough statistics’ in the Colour Manipulation Window?
I faintly remember having seen something like this before.
If this doesn’t help, the dev’s (@lveci) might have look at it.

Yes, indeed the “Rough statistics” gives the statistics of the cropped image and after refreshing the Colour Manipulation Window representation the image is displayed as normal. Thanks for the advice.

I tried reproducing the error on another images, but there the final refreshing didn’t do the trick. For me the tool also behaves strangely when applied with .xml file in the command line and GPT. Sometimes it crops the image, other time it saves the entire image and creates an additional mask of the selected polygon.