Landsat collection 2 reader

Dear developers,

In this post it is reported that Landsat Collection 2 (Level 1 and Level 2) are not yet supported:

I am wondering if the development of a specific reader has been already considered among future SNAP8 improvements.

Kind regards,

Federico