Latest updates does not read S2-products

I observed the following problem after installation of the recent SNAP updates (on Windows).

Reading L1C products with SNAP and the latest updates (engine version 2.0.1, windows x64) fails.

Reading the same product with SNAP uninstalled and new installed without updates gives proper results for the same product.

The problem doesn’t occured only for this example product. It regards both reading L1C and L2A products.

Did you update from the 2.0 version or from a beta version? Update from beta versions is not supported, you have to reinstall SNAP from scratch. Update from the 2.0 release should work.

I updated from 2.0 release.
I am looking how I can upload an attachement showing the results. With the updated version all data are set to NanN


You can just paste an image directly into your reply. Or at least I can… It’s a lot better than the MPC JIRA :smile:



On Windows 7 64, I installed SNAP 2.0.0 without S2TBX modules, then installed them via the update center, and everything worked fine. May be it is due to old data in the tile cache, do you have the problem even with products you never opened before? Could you send us the content of AppData\Roaming\SNAP\var\log of you user directory where it’s not working?

My impression is, that it occurs for re-reading products, but I am not sure. However, pointing to only re-reading is not correct. I can re-open products which I only opened and opended RGB-image window (at least some of them, I am not sure if all). I cannot reopen products which I analysed little more. I am saving images as RGB, extract spatial subsets and compute statistics. By the way: I found that (at least with the old version) the statistics results saved into csv file differ little from what is printed on screen in the statistics window.

May be it is due to old data in the tile cache. I several times updated from the old version to the new. All seems to be running and at the next morning I could not reopen the data which I analysed the day before. My quick look into the logfile you requested identified some error messages regarding the cache,

In AppData\Roaming\SNAP\var\log there are two files.

messages.log (305.2 KB)

messages.log.1 (65.1 KB)

The logs contains errors about masks, and there were some big changes for masks on the last versions, so this is probably related. Could you delete the content of C:\Users\pflug.snap\var\cache\s2tbx? Does it solve the problem?

No, unfortunately it does’nt solved the problem. SNAP now updated again and I can read the last product which I analysed, but not the ones before. I analysed them no more than 3 hours ago. However, I could open the next product to analyse.

Could it be connected with moving data? I collect the data to analyse in one directory and move them to another if I am ready. Now, after deleting the content of the cache I opened the last analysed product. It worked. Then I moved it to the other directory. I can still open it, because it is in the cache. But I could no more open earlier products, also if they are still within their original directory.

Do you mean you still have a black image after deleting the cache? And is the product cache filling up when you open products?

Yes, it is. I checked again. I delete all files in the cache C:\Users\pflug.snap\var\cache\s2tbx. The cache is empty. Then I open the product. The cache is filled with this product. Then I open RGB-image window, the window area keeps black, but the geographical coordinates of the cursor position are traced.

I copied the same product file to my Linux computer and open the product. The RGB-image is displayed without problems.

Then it might be related to the products themselves. Could you send a name of the product that is not working, or even a link to one of these product, so I could download it?

I copied one of the products on our ftp (user anonymous).

into directory put/pflug/SNAP

However, I don’t believe that it is related to the product themselves, because I can open the same product on my Linux computer.

Hallo Nicolas,

you are sitting in Toulouse? If, then we could meet on Wednesday afternoon and look together what happens. I come to Toulouse tomorrow for 2 days.

Hallo Bringfried,

Yes I am in Toulouse, and we can have a look this afternoon if it’s still ok for you.


Hallo Nicolas,

sorry, your answer was coming to late for me.