Launching error of S1 Mission program

When trying to launch the Sentinel-1 Mission program in PolSARPro v6.0.3 Biomass, I encountered an error message as follows:

can’t read “widget(PSPEDUC1)”: no such element in array
can’t read “widget(PSPEDUC1)”: no such element in array
while executing
“$widget(PSPEDUC1) configure -state disable”
invoked from within
“.top3.fra66.cpd69.but93 invoke”
(“uplevel” body line 1)
invoked from within
“uplevel #0 [list $w invoke]”
(procedure “tk::ButtonUp” line 24)
invoked from within
“tk::ButtonUp .top3.fra66.cpd69.but93”
(command bound to event)

and then the program panel is not able to use.

I wonder if it’s a problem of my TCK software or the problem of PolSARPro itself. Additionally, the PolSARpro Bio program works normally.

The runtime information as follows,
OS: Windows 10
TCL: tcl-8.6.11

Hi samlee, I have encountered a similar bwidget package problem. I was wondering how you actually fixed the issue.

I hope you can help.

I have solved the problem:

After I install PolSARPro 6.0.2 and tried to launch up sentinel 1 A/B mission, I got some error about "widget(PSPEDUC1) missing “ or alike warnings and failed start up this module.

It took me some time to figure out this is due to a misspelling in the main TCL file “PolSARpro_v6.0.2_Biomass_Edition.tcl” .

at line 51251, "$widget(PSPEDUC1) configure -state disable "
and line 51323 "$widget(PSPEDUC1) configure -state normal ",
“PSPEDUC1” in the brackets has to be changed to “PSPEDUC”, then it will work.

this message is for those who may encounter the same problem.

1 Like