Lee sigma speckle filter performance

Hello everyone,

I want to de-speckle my SAR image using the filters available in SNAP. I am doing some experiments by applying all the filters in the SAR image to see which one performs best. According to the literature, Lee-sigma is widely used and perform best compared to other filters. So, when i run Lee sigma filter the result is exactly the same with my original SAR image. It looks like noise is still present. Please, see my images attached.

On the left, original image is shown and on the right , the de-speckled (both are exactly the same). On the bottom we can see the histogram of both the original and the de-speckled image which is exactly the same.

Is something wrong with this filter or this is how it performs?
I tried different windows, but the results are exactly the same


Maybe some questions which might help to explain this :
Which window sizes did you test?
What is your data and resolution?
Is the data in slant or ground geometry?
At which step of processing did you filter?

Hi Abraun,

The SAR data I am using is in Ground Range Detected format. The resolution is 40 x 40 (Extra wide swath mode).
I have tried all window sizes, but the results are surprisingly the same. No difference from the original image.

I first calibrated the data and then I applied speckle filtering. All the other filters work fine. The only one that does not do work properly is the lee sigma.

Lee sigma is supposed to be the most popular and effective filter for suppressing the noise in SAR images but in my case there is no difference between original and the image that has been de-speckled after applying lee sigma filter.


Sounds like it’s either a bug or there’s something not right with your SNAP-installation. Are other seeing the same behaviour?

I am using SNAP 5.0 version.
I have tested all filters available in SNAP. I get the results I expect to get. When I run Lee sigma, using all window sizes, the results are exactly the same with my original SAR image. I do not know if it is a bug, but something does not work quite right.

(I have not encountered any issue with SNAP (in general) so far, all tools work fine. This means that the SNAP installation is fine.)

works in my case (quick test on ALOS-2, 6m)

Did you check the statistics tool if the rasters are really unchanged?

I don’t know if the size of 40 meters produces an image that is always below the ‘normal’ speckle threshold of the Lee Sigma filter. Additionally, GRD images are alread resampled and in ground range geometry while some SAR filters perform best at slant range images.
So it could be that the filter worked but just not very effective. But your images are a bit suspicious because absolutely no effect can be seen and Lee Sigma usually is one of the stronger filters.

1 Like

thanks for your example. SO, the lee sigma filter works fine
Are your ALOS data in slant range geometry?
Did you apply the filter before data calibration?


I applied Lee sigma on my SAR image before calibrating it and it works fine.
Once I calibrate the image and then apply Lee sigma filter, for some reason it does not work very well

my data was in slant geometry but calibrated. I just saw that you applied it on data in db scale. That’s not always very fortunate.
Try to apply it on the calibrated but power scaled data (gamma instead of distribution of the histogram).

1 Like

yeah, that’s what I have realized.
I do not have to apply the filter in db scale

thanks :slight_smile:

you can convert to db afterwards. But as the raster values lie closer together in the db scale, the filter doesn’t perceive them as different.

yes, you are right. It took me some time to realize that

Dear all,

I am working with both ERS-2 and Sentinel-1 imagery and have a question regarding the parameters of the Sigma Lee filter. The algorithm has a parameter NL (number of looks), which I always interpreted as a parameter inherent to the image. It would be 3 for ERS-2 precision imagery (https://earth.esa.int/web/guest/data-access/browse-data-products/-/article/sar-precision-image-product-1477) and 6 for Sentinel-1 IW GRD imagery (https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/resolutions/level-1-ground-range-detected). However, the dropdown menu for the NL parameter only allows values between 1 and 4, so I started to doubt about the meaning of this parameter…

Any help would be appreciated!

Thanks in advance,