Linux Command - Update Snap Not Working

I’m following the instructions here to update SNAP:


I am running a graph processor in the cloud and encountering a null pointer error with the SAR Mosaic operator. I tried running the graph at my desktop and I got the same error, so I checked for updates and sure enough, there was an update to be installed which fixed the null pointer error. However, I can’t seem to install the update via the commandline on my linux machine. Any suggestions?

I noticed that the server was temporally down during the last days.

But your error is related to the DISPLAY variable which prevents correct return of the actual error message. I’m not an expert with Linux but maybe you find answers here:

The warning message should not be a problem.
I get this too. It just telling you that you don’t have a display. Which is okay.
But I also get a list of updates.
Also, the updates are done properly.

I get the same message as you, when I have already the latest updates.
After processing, you can see the version of each operator in the metadata, at least if you save it as BEAM-DIMAP.

Either you have already the latest updates or your cloud server does not allow to connect to the snap module updatecenter. Maybe you are behind a firewall or a proxy? But I guess, there would be some error message indicating it.
Maybe check the last section of the wiki page about “Configure Proxy without GUI”

Definitely don’t have the latest updates. With --refresh --list its not showing any of the available upgrades.

What port do the updates requests operate under? You’re probably right about the firewall. The security settings on the cloud instance probably don’t allow the traffic and update requests.

Ah, you are still on version 5.
To get version 6 and its updates you need to reinstall SNAP.
So you have already the latest updates for the old version 5 branch. There is no way to update from one major version to the other.

The update process only needs simple http-requests. Nothing special. So it should work in the most cases, but you never know…

Actually after looking at the in/out rules, all outbound communication is allowed, so unless the server is making requests back at my machine, that shouldn’t be the problem.

There we go, must have grabbed the wrong install for this machine.