Loading error within Windows 10

My PC has recently been upgraded to Windows 10 and since then SNAP has not been working. At first I thought it may be due to lack of admin rights as the program was accessing files from the OS drive. I gained admin rights and the problem persists. I ran the snap64 within the command-line prompt and received the following error:

Error 1: Can’t load requested DLL …from C:…: %1 is not a valid Win32 application.

A fatal error has been detected by the Java Runtime Environment.

Exception Access Violoation (0xc0000005)…

I ran the program in admin mode and receive the same error. The program simply shuts down within about 1 second of loading the GUI.

Any insight on this issue would be much appreciated.

Kind regards,


Uninstall and re-install the 64-bit version.

I have tried to re-install (I am running the 64 bit application) and it continues to give the same errors. I just tried to run under Win7 compatibility and that doesn’t work either.

Can you be more specific what kind of windows 10 do you have ? x86 x64?
Java version?
Microsoft Visual environment installed ?

What kind of SNAP version are you trying to install ?

I am running Enterprise Windows 10, x64, Java version 8 Update 191, and I do have Microsoft Visual environment installed. I believe the version of SNAP I am trying to install is 6.

Many people have installed SNAP on Win10 64-bit, so whatever is happening is somehow related to your system.

That is what I was afraid of. I have read through the forums and understand it is compatible, so I can’t understand what the issue is. I have a colleague who has installed it on his PC (same specs as mine) and it doesn’t work either.

I’ll cross-reference to SNAP - Problem with Windows 7 . Windows Event Log should have more specific information about the error.

I had a case once where SNAP didn’t start properly, but when the internet connection was disabled before/during the start, the problem was somehow solved.
But “access violation” sounds a bit worse, I’m afraid.

I’ve some question about your system. Was the previous Win7 OS also 64Bit or was this still 32Bit?
Did your colleague used the same downloaded installer or did he downloaded the installer himself? Did his system undergo the same update procedure?
When you see this access violation exception, then there is also a log “hs_err_pid.log” created. It should be located in the bin folder of the SNAP installation directory. Can you attach it here, please?
It could be that you have an issue with your graphics card. An update of the driver could help.
I hope the log file gives more details.

Hi all,

I would like to thank you for helping out with this issue. I have since had the issue resolved and can provide some details in case others are experiencing the same issue.

It appeared to be a graphics card issue, although the driver was said to be up to date. I had to un-install the AMD graphics software and install the latest drivers from the AMD site. I have tested out SNAP and everything is working perfectly now.


1 Like

Thanks for reproting this back. I’m happy to hear that you have solved it.

1 Like

Error after launching SNAP

I just now updated the SNPA, I have windows 10, Dell laptop with 16 GB RAM, and win64, windows 10 is original in the laptop, since I bought it two months ago, the error is below,

Hope to get an assistance to solve this error, many thanks in advance,

java.nio.file.InvalidPathException: Illegal char <"> at index 0: "C:\Program Files (x86)\Common Files\Oracle\Java\javapath
at sun.nio.fs.WindowsPathParser.normalize(Unknown Source)
at sun.nio.fs.WindowsPathParser.parse(Unknown Source)
at sun.nio.fs.WindowsPathParser.parse(Unknown Source)
at sun.nio.fs.WindowsPath.parse(Unknown Source)
at sun.nio.fs.WindowsFileSystem.getPath(Unknown Source)
at java.nio.file.Paths.get(Unknown Source)
at org.esa.s2tbx.dataio.gdal.activator.GDALDistributionInstaller.findFolderInPathEnvironment(GDALDistributionInstaller.java:213)
at org.esa.s2tbx.dataio.gdal.activator.GDALDistributionInstaller.processInstalledWindowsDistribution(GDALDistributionInstaller.java:179)
at org.esa.s2tbx.dataio.gdal.activator.GDALDistributionInstaller.install(GDALDistributionInstaller.java:67)
[catch] at org.esa.s2tbx.dataio.gdal.activator.GDALPlugInActivator.start(GDALPlugInActivator.java:22)
at org.esa.snap.runtime.Engine.informActivators(Engine.java:222)
at org.esa.snap.runtime.Engine.lambda$start$0(Engine.java:121)
at org.esa.snap.runtime.Engine.runClientCode(Engine.java:189)
at org.esa.snap.runtime.Engine.start(Engine.java:121)
at org.esa.snap.rcp.SnapApp.onStart(SnapApp.java:364)
at org.esa.snap.rcp.SnapApp$StartOp.run(SnapApp.java:500)
at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1443)
at org.netbeans.modules.openide.util.GlobalLookup.execute(GlobalLookup.java:68)
at org.openide.util.lookup.Lookups.executeWith(Lookups.java:303)
at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2058)

@kraftek, @oana_hogoiu can you have a look. It seem to be related to the GDAL plugin.

1 Like


Could you please check the environment variables on your Windows (type “environment variables” in Start", then select “Edit the system environment variables”, click “Environment Variables” and double-click the “Path” variable in the System Variables section. The respective path (C:\Program Files (x86)\Common Files\Oracle\Java\javapath), does it contain any " ? If yes, please remove it.


1 Like

Hi Cosmin,

Thanks a lot for your response, the path is as bellow, So to remove the bolted line, if I got your point correctly!

C:\Program Files (x86)\Common Files\Oracle\Java\javapath;”;C:\Program Files (x86)\Intel\Intel® Management Engine Components\iCLS;C:\Program Files\Intel\Intel® Management Engine Components\iCLS;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Windows\System32\OpenSSH;C:\Program Files (x86)\Intel\Intel® Management Engine Components\DAL;C:\Program Files\Intel\Intel® Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel® Management Engine Components\IPT;C:\Program Files\Intel\Intel® Management Engine Components\IPT;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\Intel\WiFi\bin;C:\Program Files\Common Files\Intel\WirelessCommon;C:\Python27\

1 Like

Not to remove it entirely, but just the quotes (").

1 Like

Thanks a lot it solved the problem,

I found with version 8 the same previous error pop up when launch sanp, but the previous solution doesn’t work, because the quotes are already not exist, the error is,

java.util.ServiceConfigurationError: javax.xml.stream.XMLInputFactory: Provider com.ctc.wstx.stax.WstxInputFactory not found
at java.util.ServiceLoader.fail(ServiceLoader.java:239)
at java.util.ServiceLoader.access$300(ServiceLoader.java:185)
at java.util.ServiceLoader$LazyIterator.nextService(ServiceLoader.java:372)
at java.util.ServiceLoader$LazyIterator.access$700(ServiceLoader.java:323)
at java.util.ServiceLoader$LazyIterator$2.run(ServiceLoader.java:407)
at java.security.AccessController.doPrivileged(Native Method)
at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:409)
at java.util.ServiceLoader$1.next(ServiceLoader.java:480)
at javax.xml.stream.FactoryFinder$1.run(FactoryFinder.java:353)
at java.security.AccessController.doPrivileged(Native Method)
at javax.xml.stream.FactoryFinder.findServiceProvider(FactoryFinder.java:341)
Caused: java.lang.RuntimeException: Provider for class javax.xml.stream.XMLInputFactory cannot be created
at javax.xml.stream.FactoryFinder.findServiceProvider(FactoryFinder.java:367)
Caused: javax.xml.stream.FactoryConfigurationError: Provider for class javax.xml.stream.XMLInputFactory cannot be created
at javax.xml.stream.FactoryFinder.findServiceProvider(FactoryFinder.java:370)
at javax.xml.stream.FactoryFinder.find(FactoryFinder.java:313)
at javax.xml.stream.FactoryFinder.find(FactoryFinder.java:227)
at javax.xml.stream.XMLInputFactory.newInstance(XMLInputFactory.java:154)
at gov.nasa.worldwind.util.WWXML.openEventReaderStream(WWXML.java:353)
at gov.nasa.worldwind.util.WWXML.openEventReader(WWXML.java:502)
at gov.nasa.worldwind.util.WWXML.openEventReader(WWXML.java:464)
at gov.nasa.worldwind.ogc.OGCCapabilities.createReader(OGCCapabilities.java:89)
at gov.nasa.worldwind.ogc.OGCCapabilities.(OGCCapabilities.java:70)
at gov.nasa.worldwind.ogc.wms.WMSCapabilities.(WMSCapabilities.java:71)
at gov.nasa.worldwind.util.SessionCacheRetrievalPostProcessor.handleWMSCapabilitiesContent(SessionCacheRetrievalPostProcessor.java:248)
at gov.nasa.worldwind.util.SessionCacheRetrievalPostProcessor.handleContent(SessionCacheRetrievalPostProcessor.java:238)
at gov.nasa.worldwind.util.SessionCacheRetrievalPostProcessor.onRetrievalSuceeded(SessionCacheRetrievalPostProcessor.java:193)
at gov.nasa.worldwind.util.SessionCacheRetrievalPostProcessor.run(SessionCacheRetrievalPostProcessor.java:177)
at gov.nasa.worldwind.retrieve.URLRetriever.end(URLRetriever.java:352)
at gov.nasa.worldwind.retrieve.URLRetriever.call(URLRetriever.java:280)
at gov.nasa.worldwind.retrieve.URLRetriever.call(URLRetriever.java:27)
at gov.nasa.worldwind.util.SessionCacheUtils.retrieveSessionData(SessionCacheUtils.java:80)
at gov.nasa.worldwind.util.SessionCacheUtils.getOrRetrieveSessionCapabilities(SessionCacheUtils.java:170)
at gov.nasa.worldwind.terrain.BasicElevationModel.retrieveResources(BasicElevationModel.java:2028)
at gov.nasa.worldwind.terrain.BasicElevationModel$3.run(BasicElevationModel.java:2118)
[catch] at java.lang.Thread.run(Thread.java:748)

Dear @marpet @ABraun If you have any answer to this issue.

Hi Falah,

This has been reported already.
Search results for ‘WstxInputFactory’ - STEP Forum (esa.int)
You can safely ignore it. In some cases, it might affect the WorldView, but not always.

1 Like