Lt data in nc format downloaded from NASA could not be displayed entirely

When I open a scene of Hico L1 data from NASA oceancolor webset, the Lt data contained in it is hidden and could not be displayed. SNAP version 8.0 :worried:
BUT! It could be shown entirely in SeaDAS.

Using fully updated SNAP 8 on Windows 10, loading the same file (using “Files of type”: HICO L1B) and the Lt bands are listed. Product Explorer uses the name: iss.2014075.0316.040304.L1B.hico.unknown.v01.15683.100m.h5.

If you are still having the problem, please provide more information about how you are loading the file and your platform.

The data file was downloaded from ’ [NASA Ocean Color] (’.
And my platform is windows 10.

I tried again, and with the ‘import - optical sensors - HICO L1B’ path, there is still the same bug.

The data reader available at Import / Optical Sensors / HICO L1B was made for a different dataset provided in ENVI format. It was available here: HICO - Hyperspectral Imager for the Coastal Ocean (
It seems this is not accessible anymore.

SNAP does not show the Lt bands of the HICO NetCDF file because they are stored in a multi-dimensional variable. This is currently not supported by the standard NetCDF reader.

But the provided *.bz2 files can be opened in SNAP and show the Lt bands. This was implemented by the SeaDAS guys to support the format provided by the Oceancolor Data page.

But you need to have installed the Sentinel-3 Toolbox in SNAP.

So, if there is only .nc format provided (below), the file could not be entirely opened in SNAP ? I’ve installed the Sentinel-3 Toolbox.
I’ve noticed the file name in the screenshot (iss.—.hico.unknown.v01.—.h5) is not the same as mine, and i guess its source is different.

Here you should find the corresponding bz2 file to your nc files:
HICO/L1/2014/075 (

:smile: Thank you very much!!