Mandatory source product (field 'sourceProduct') not set

I have this graph wich helps me pre-proessing a number of ENVISAT images:

Works fine, but some terrain effects remain.

When I add the Terrain Flattening module I get an error:
Error in graph: [NodeId: Terrain-Correction] Operator ‘RangeDopplerGeocodingOp’: Mandatory source product (field ‘sourceProduct’) not set.

As you can see, Gamma0 is displayed as an input but obviously not recognized by the graph.

Any idea how to fix this or why the error occurs at all?

got it working by myself. Somehow, there was a .1 inserted in the sourceProduct tag when creating the xml-file. I removed it in the xml, saved and imported the graph again. Now it works. Maybe a bug?

The error message occured when I deleted a connection in the old graph (remove source) to insert the additional module TerrainFlattening. Could be that there went something wrong internally.

These are the xml files:

<node id="Terrain-Correction"> <operator>Terrain-Correction</operator> <sources> <sourceProduct refid="Apply-Orbit-File"/> </sources> <parameters class="com.bc.ceres.binding.dom.XppDomElement"> ... </parameters> </node>

not working
<node id="Terrain-Correction"> <operator>Terrain-Correction</operator> <sources> <sourceProduct.1 refid="Terrain-Flattening"/> <-here :slight_smile:
</sources> <parameters class="com.bc.ceres.binding.dom.XppDomElement"> ... </parameters> </node>


I investigated this some more:

The problem re-occurs every time you insert a new module into an existing graph and place it between two connected modules, and remove the old link respectively.
This somehow adds the .1 in the source product tag in the XML file which makes the graph incomplete.



I have similar case, I’m applying backgeocoding using gpt, my XML file has been edited up by removing the number .21 but still I have the same error,


could it be at another step in your XML? Maybe <sourceProduct occurs several times.

this is a screenshot of the XML file, Did you mean the highlighted, if yes, how to avoid this happened?

it can occur multiple times (whenever a new or intermediate product is read), so that is okay. What product is passed to the XML? Looks like the overall input for the graph (first occurence of <sourceProduct is invalid).

they are split and orbit applied S1, 21 images, (Is that what you’re asking for!)


I meant how the product is handed over to the script. What is the command you execute to start the processing?

first I cd to the path where the XML is existed, and then I used the call gpt graph.xml

the source of product is already set it in the graph so, I think there is no need to add source data to the gpt,

I see. Isn’t this your answer then? ProductSet-Reader fails with gpt command line utility

I am not very experienced with manually editing XML graphs, sorry.

The solution in here,

1 Like