MemoryError sen2cor for 10m res

Is anyone else getting MemoryError while processing an L1C data product at 10m res? I have tried it on a number of different virtual machines to no avail. It works with 20m res.

Sen2Cor version 2.0.6
VM Memory ~ 5GB.
Data file size ~ 500MB.

Tried with 10m res:
Progress[%]: 19.72 : Traceback (most recent call last):
File “/root/anaconda2/bin/L2A_Process”, line 9, in
load_entry_point(‘sen2cor==2.0.6’, ‘console_scripts’, ‘L2A_Process’)()
File “/root/anaconda2/lib/python2.7/site-packages/sen2cor-2.0.6-py2.7.egg/sen2cor/”, line 283, in main
result = processor.selectAndProcess(tile)
File “/root/anaconda2/lib/python2.7/site-packages/sen2cor-2.0.6-py2.7.egg/sen2cor/”, line 89, in selectAndProcess
self._processed10 = self.process()
File “/root/anaconda2/lib/python2.7/site-packages/sen2cor-2.0.6-py2.7.egg/sen2cor/”, line 148, in process
if(ac.process() == False):
File “sen2cor/”, line 1286, in sen2cor.L2A_AtmCorr.L2A_AtmCorr.process (L2A_AtmCorr.c:27391)
File “sen2cor/”, line 6091, in sen2cor.L2A_AtmCorr.L2A_AtmCorr.dtm_flat (L2A_AtmCorr.c:139780)

[root@sentinel ~]# du -ksh Sentinel/S2A_OPER_PRD_MSIL1C_PDMC_20151223T044026_R036_V20151222T095928_20151222T095928.SAFE/
510M Sentinel/S2A_OPER_PRD_MSIL1C_PDMC_20151223T044026_R036_V20151222T095928_20151222T095928.SAFE/

The processor is able to perform a 10 m image without background pixels (a full scene) with a memory of about 6 GB. Below the value of 6GB it might work, but this is dependent on the amount of existing non background pixels. The reason for this huge memory consumption is the fact, that for some of the atmospheric calculations (AOT) a collection of full arrays of size 10.000 x 10.000 must be kept in memory, as otherwise artifacts due to tiling will occur. So in your case, the size of 5 GB seems to be a bit to low … The memory errors you observe occur in a function call of the scipy Rect.BivariateSpline function, outside of the sen2cor code, so no real chance to fix it on the fly …

hello, did you fix the problem? I am facing the same error. I will appreciate it if you can share the solution.