Message: Cannot Create data buffer

Hello sir,

I am using sentinel-1 SLC date which is operated in IW mode during calibration I got the message, “cannot create data buffer”. While I am using high end configuration system for SAR processing i.e. 16 GB RAM with i7 processor.

Please suggest me, how to resolve this problem?

Thank You

sometimes it helps to unzip the S1 data before importing it into SNAP. This saves some memory required for the unpacking.

I already did this step

I wouldn’t consider a 16Go RAM system as a high end configuration system. until you close SNAP, the memory is not free (even if not used). It means that if you are working for a long time without closing, your ram can quickly be saturated.

I still have this issue though I have 64Go. My solution is :

  • Open a terminal
  • write the “htop” command
  • If you begin to be saturated, close snap to reset memory

example of htop output (numbers are the cores/threads and Mem is your RAM

Also, in Tools -> Options -> Performances, you can check if all the ram of your system is allowed to be used by SNAP

Can you please tell me how can I resolve this memory issue?

In Options/S1TBX check the box that says “use FileCache in readers to conserve memory”. This should help somewhat.