Missing vectors on vector training box


I am trying to do a supervised classification.
I did all the steps already mentioned here:

But when I open the KNN classifier window, the part with the training vectors is empty and I get that footnote “Error: [NodeId: KNN-Classifier]node”:

Anyone knows why could this be happening?


1 Like

did you save your product already?

“subset_0_of_” indicates that you made a subset on-the-fly but didn’t save it with File > Save as…

Newly created geometries need to be stored in the product in the saving process.

Hi @ABraun!

Yes, I saved product and also tried save product as (and gave another name).
When I open the product, I can see it has inside the vector data file, there are the names of the vectors that I created.

hmm, that’s strange.
Did you try another classifier just to see if it is just the module or a consistent problem?

Your samples are polygons? Sorry for asking but I try to find possilbe error sources.

Hello ABraun,

I’ve the same problem -> warning window “Error: [NodeId: Maximum-Likelihood-Classifier] node”.
I’m using S1 IW SLC data and two polygon shape data.


1 Like

Yes, they are polygons:

I tried with all classifiers, and I get the same error type.

Hello Sara,

I got through the problem! Try to delete the “masks” and then add your data into the classifier. It should work ;)!


If this is related to the masks. The problem has been fixed but not yet released as an update. I’ll look to release it next week.

Hello lveci,

I think it is, but I’m not sure :smiley:

I will let you if it worked with me once I try it out ; )

Yeah! Let me know because I need to see which result you can work out!

Hello all,
I have the same issue when using any of the supervised classification method. The image produced is invalid. I erased the masks, but the problem remains. Any update about this?

Hello Hugo,

what do you mean with “the image produced is invalid”?

do you write your output as as jp2000 file?
I would rather stick to the Beam DIMAP format until the last step of your analysis.

I used the DIMAP as first choice, but as other users reported before, the classification process gave a blank image. To have a look at the image using othe softwares, I made some tests with more usual image data formats. But the results are the same.

Dear Piero, I am finally back to this. What do you mean with ‘delecting the mask’? How can I then select the training places? Thanks !

Dear Luis @lveci

Has the update been released already?
Thank you very much

Hello Sara,

I mean if you delete the masks you still have the vector (see the image)

Right click and delete.

Then you can run the “Classification” processor. I think this is a kind of “bug”.

Let me know!



Thanks so much Piero @Piero_Sciusco !
It does move forward now, they do appear and I am able to ‘Run’ !
However, I get a blank (black) screen, when I open the labeled classes and confidence… : (