Missing vectors on vector training box

do you write your output as as jp2000 file?
I would rather stick to the Beam DIMAP format until the last step of your analysis.

I used the DIMAP as first choice, but as other users reported before, the classification process gave a blank image. To have a look at the image using othe softwares, I made some tests with more usual image data formats. But the results are the same.

Dear Piero, I am finally back to this. What do you mean with ‘delecting the mask’? How can I then select the training places? Thanks !

Dear Luis @lveci

Has the update been released already?
Thank you very much

Hello Sara,

I mean if you delete the masks you still have the vector (see the image)

Right click and delete.

Then you can run the “Classification” processor. I think this is a kind of “bug”.

Let me know!



Thanks so much Piero @Piero_Sciusco !
It does move forward now, they do appear and I am able to ‘Run’ !
However, I get a blank (black) screen, when I open the labeled classes and confidence… : (

Can you post a screenshot please?

They look both like this.
(I also let the window of the classifier open so you could see what how I selected…)

Mmh, tell me if I’m right… are you using S2 data ? Because I’ve never done the Classification with this kind of data. Maybe you can wait if someone have the right solution about this.

I have been reading a similar problem in this forum, and it can be linked to the fact I did not reprojected my data. I will give it a try and see what happens. Maybe the problem could actually be there.
(Yes, it is S2 data)/

1 Like

Hi there Sara, Did the reprojected data workout now? I have been experiencing this problem with classifying the S2 data.
Also when I export the data into another software like ArcMap, the projection is lost and trying to redefine it is impossible. Can anyone help?

I am doing it right now. As soon I finish I will let you know @angie ; )

1 Like

Didn’t worked out even after reprojection. I had hopes it would work out because of this post:

Thanks Sara for the feedback.
It is a challenge and hope someone could guide on this. also on the exported data files with defined projection.

1 Like

I think it should be with the latest update. Are you using snap-engine 5.0.3?

1 Like

Actually not. It’s 5.0.
I will update.
Thank you very much @lveci

I took a look on set.esa.int/main/download and it says that current version is 5.0.0 (05.12.2016 14:40).
Where/how can I find snap-engine 5.0.3 ?
Thank you !

Minor version updates are only distributed via plugin updates.
Go to Tools / Plugins and check for the version there and/or update SNAP and the toolboxes.
You can also go to Help / Check for Updates.
In general you are notified about updates by a balloon message in the lower right.

1 Like

@marpet @lveci I update SNAP, now the problem of of the masks are gone. When I want to run a supervised classification, I simply need to draw the vectors and they will automatically appear in the classfication window. Howeve, I still get a get nothing when I Run.

I can see the ID of the classes with values -1, 0, 1 ,2 but nothing else…

Hi everyone, after 3 years I am having the same problem. Some of my vector data containers had 0 features, so I tried over and over again until somehow the features were counted. Once I overcome that problem, I ran the supervised classification, and after waiting for like 10 minutes, the result was empty.
You guys said that I should reproject first, and I will try, but… boy that takes a long time…
Wish me luck.
Sara, if you are still around, please catch me up on how to solve this issue.

Thanks a lot.

1 Like