Mt_prep_snap problem

After I executed the mt_prep_snap command, I encountered the problem shown in the figure below. Does anyone know what to do? Thank you, please :pray: :pray: :pray:

When asking for help in online forums, everyone benefits if you make your post easy to read for all forum users. This gives you a better chance of reaching someone who knows the solution, and can benefit the next user who encounters the same problem. Ideally the error message should be posted as text along with the English translation. This allows other users to find your post in a search or translate the error message to another language.

The critical information is the error message (shown in red) from matlab, but many of us can’t read the message without translation. You can directly paste matlab output as text, or post your own translation of the error message.


I 'm sorry, I didn 't notice this detail, which caused you inconvenience.
Its translation is probably

/ bin / bash : mt _ prep _ snap : no command was found

Error using load
Unable to read file '… / '. There is no such file or directory.

Error ps _ load _ initial ( line 54 )
day = load ( dayname ) ;

Mistake stamps ( line 283 )
ps _ load _ initial ;

Error runtamps _ 1 ( line 21 )
stamps ( 1,1 ) ;

No need to apologize – there is an art to making effective use of online forums. SNAP is a very large and complex system with a small group of developers, so documentation is often lacking and the forum is an important source of information.

Please look at Error in running mt_prep_snap. “slc.par” and “matlab: Command not found.” - s1tbx / STaMPS - STEP Forum ( to see if any of the suggestions there apply to your case.

1 Like

Thank you for translating.
Looks like the StaMPS configuration file does not point to the folder containing all scripts or this file was not sourced correctly. Can you please check if this is the case?

Hello, this is the script I want to call. I have just stepped into this field, so many things are not understood. If not clearly expressed, please forgive me. I do not know how to find the script in this website. Therefore, I have found a paper written by the blogger himself elsewhere to call the exported data. When I use mt _ prep _ snap alone, he will also prompt that no command is found. I have also looked at some articles in this forum, but it seems that I did not find what I wanted.

No problem. To get there please check these instructions. They all refer to the same workflow, but from slightly different viewpoints. StaMPS - Detailed instructions - #2 by ABraun

In particular, I recommend this one, because it includes installation as well and explains all steps in detail: StaMPS/ · master · Matthias Schlögl / gis-blog · GitLab

I’m sure you can run the scripts once you have installed the software correctly and the data structure is prepared as required by StaMPS.

Thank you. I ’ ll try it right now. I ’ m really moved to have this forum to help if I can 't find help.

Hello, when I looked at the advice you gave me and took action, I found that running stamps ( 1,1 ) wasn 't the last mistake, but something else, I wanted your help.
Translation :
Error using ps _ load _ initial _ gamma ( line 36 )
. ./ rsc. txt does not exist

Mistake stamps ( line 263 )
ps _ load _ initial _ gamma ;

hi,just solved the “mt_prep_snap” problem, the reason why “mt_prep_snap” not found is its environment variable not been added in the path of matlab. it could be solved by such command in matlab

path1=[path1 ‘:usr/STAMPS/bin’]; %your mt_prep_snap path

and use !echo $PATH to check
But I still can’t solve the problem "error using load, can’t find ‘…/’ ",do you have any idea of this?
By the way, have you watch the video from bilibili?

The question is not clear. can you share the screenshot of that particular error?

yeah, of course, problem just as same as this (picture from @ABraun )

Use the latest version of stamps4.1b (below link providing latest one).

dbekaert/StaMPS: Stanford Method for Persistent Scatterers (

Thanks, but my StaMPS is the latest version, still got the problem


Have you completed the mt_prep_snap step successfully?

I think mt_prep_snap is successful

1 Like

thanks a lot, had read this and reinstalled the matlab, it doesn’t work

Your screen capture has" version ‘CXX_1.3.9’ not found (required by ???". You would do better to past the Matlab messgaes as text so we can read the entire message. You should contact Matlab for help with Matlab errors: Ther you will find: Matlab Answers: libstdc-so-6 CXXABI_1.3.9 not found

This issue might be due to an incompatibility between the libstdc++ shipped with MATLAB and the libstdc++ shipped with the system that the other application was linked against.

1 Like

Thanks a lot, I had fixed the “cxx_1.3.9” problem, it looks right now, but the “load” problem still exist