Mt_snap_prep not finding selpsc_path, psclonlat, pscdem and pscphase commands

Good evening all!
I’m a new user of snap2stamps, so I already thank in advance whoever will try to help me.
The reason for my new topic is that I’m having an error when I run the mt_snap_prep script.

What I have done until now is (after obviously have done every other previous step smoothly):

  1. I created a new folder “stamps” in the project folder;
  2. in this folder I call the terminal and I write source /…/StaMPS_CONFIG.bash (after having modified the script with the correct dir of StaMPs 4.1b, Triangle (bin) and Snaphu (bin) and the addition of a last line exportPATH=${PATH}:$STAMPS/bin:$MATLABPATH);
  3. If I call mt_prep_snap master_date /…/INSAR_master_date/ 0.42 is giving me mt_prep_snap command not found, I tried also removing the last / from /…/INSAR_master_date, again not working;
  4. similarly to the previous steps, I tried with copying in the new stamps folder all the files present in the bin folder of StaMPs 4.1b and if I call mt_prep_snap master_date /…/INSAR_master_date/ 0.42 is working…but is giving the errors shown in the screenshots.

Somehow it does not find the files selpsc_path, psclonlat, pscdem and pscphase commands.

What I am doing wrong?
I followed the workflow as showed but I don’t know why is giving me this.
I have respectively 6 (1B-Asc) and 8 (1A-Asc) slave images (I need to check if the artificial permanent scatterers we have installed are visible, so I am considering only the images from the 12/10/2021 until now).

Additional info:
“StaMPS should be compiled in gcc-7” - I checked and is gcc-7 selected with the *.
I don’t have the Segmentation Fault (core dumped) error.
Interferograms after the seem normal, also the intensity images.

Thanks again in advance!
Hope to find a solution!

Just add the path of your stamps upto bin folder in .bashrc file like below

export PATH=/home/user/stamps/bin:$PATH

Then run

source .bashrc

Your suggestion has worked! Thanks!!!

I add to your solution that I relocated the StaMPS_CONFIG.bash. with the line you told me in the same folder “stamps” where I copied&paste (as previously said) all the StaMPs 4.1b bin folder.

Thank you so much again!

1 Like

Dear suribabu
I updated etc/bash.bashrc as follows,added ‘export PATH=/home/zzz/StaMPS/StaMPS-4.1-beta/bin:$PATH’ to the bash.bashrc

Still reporting errors as follows after running ‘mt_prep_snap 20170107 /home/zzz/INSAR_master_date/stackexport 0.4 5 5 50 50’

Thanks again in advance!
Hope to find a solution!

I have problem with function mt_prep_snap.

When i run it, i noticed that i have incomplete files in folder PATH_1 and when i run command stamps(1,1) in MATLAB it show me error in ps_load_initial gamma (line 108).

How can it be solved?