NaN value after calibration


I am using TSX product for my project. When I calibrate the product, I get NaN value at many location in the image.

I am unable to know the reason. Is there any procedure to replace NaN value. Kindly do let me know as it is very important for my research.


Dear Sushil,

Since you do not provide the necessary information to recreate the issue it is impossible to comment what might have gone wrong.


The default no data value is usually 0 in products. Right click on the band and open the properties. Uncheck use no data value. If these are valid zeros then with this unchecked you should be able to use them as you wish.

@mengdahl…Hi, I will try my best to make you understand the situation

Hello sir,

Sorry sir, I could not understand your answer. As I have seen that no data value is already unchecked.

I want to remove NaN values from my calibrated product. There are countless such values. Kindly help me to troubleshoot the problem.


If it’s not using the no data value, I’m not sure where NaN could be
Please provide the type of product being used and what processing was
applied to it.

Sir, its SSC product of TerraSAR-X. When I apply Radiometric calibration to it, the product generated contains many NaN values. I don’t know how to troubleshoot it.

Sir, when I open the properties of any of the calibrated TSX products generated from the SLC product, No data value is checked. Do I need to uncheck before proceeding further for coherency matrix generation and decomposition?