Navigating in Linux

I am trying to load a graph i had saved when using SNAP on my Linux machine.
I know that it is in home/user/.snap but when i try and navigate to that folder the window does not show any of the folders with the . prefix.
I have tried re starting SNAP, but no success.
Does anyone know how to resolve this issue?

Better to save on other folders except C drive. mnt/drivename/

I don’t think you understood the question @suribabu.
In the .snap folder there is a folder called ‘User Graphs’ which is where SNAP wants you to save user graphs. Unfortunately, if you navigate away from this folder in the built in folder browser, you cannot get back to it. The built in folder browser also seems to remember where you last were in any operation, and the .snap folder is seen as a ‘hidden’ folder so won’t be displayed.
Yes you can save a graph in a different folder, or drive - but then why have the 'User Graphs folder at all if it cannot be accessed?

Sorry mattcopper. I though how to open Linux snap graph file in windows (Dual boot). I will check it in my Ubuntu PC and I will update you.

The dot prefix is used to hide files and foldes in Linux filesystems… you should check the file manager for settings to show hidden files…

From a console/command line you can use “ls -a” (with any other option like -l) to list files in that directory and check if the files are really there.

Thankyou for your reply, but I think you too have misunderstood the question.
I understand about hidden files and how to display them in the file manager. My issue is with the folder browser within snap that pops up when you select ‘load graph’ or ‘save graph’ in the graph builder. (or indeed have to choose a file from anywhere in SNAP. This browser does not display the hidden files and so you cannot get to the .SNAP folder.

sorry - that’s a different problem… I don’t have a linux system at hand to try this out… perhaps one of the other members can help… otherwise @marpet perhaps you can open an issue on Jira for this!

Hi Mattcooper,
Just know i checked in my Ubuntu PC, It is working. I saved graph file in .snap/graphs/user Grpahs/ and it is opening in Batch processing.

Better to try to open snap in root (sudo -i). I think it will work

Thanks, @mattcooper for pointing this out.
I’ve created an issue for this: [SNAP-1431] File dialog does not show hidden folder like ‘.snap’.

There is also a workaround for it.
You can enter the folder name ‘.snap’ and then press OK. The dialog will navigate in to folder.

1 Like

Thanks for that workaround, I had tries entering the filepath but it didn’t seem to work. Your method works fine though :slight_smile: