New versions of Snap Hangs when reading a file


I am having problems with newer versions of SNAP on a new PC.

Using Snap 3.0 the program starts reading the file, I can select the UTM zone and the resolution, but then nothing. No error message.

Tried Snap 4.0 can only select “native” resolution (not 10, 20 60m). However this produces the error message “Invalid openjpeg executables”

Tried going back to the orginal SNAP 2.0 for windows but get the message “missing files”

Any ideas?


This sounds like that there is something remaining from the SNAP 3 in the SNAP system directories.
Please try to delete the .snap folder in your user home directory and also the SNAP folder in <USER_HOME>\AppData\Roaming

For changing the resolution you need to use the Resampling operation. You find in the menu at Raster\Geometric Operations\Resampling.
Please see also this thread About the 10m, 20m and 60m readers removed in S2TBX 4.0


Followed your suggestion and removed all SNAP-related folders - but still get the same error message.
Tried SNAP 3.0 (removing all SNAP-related folders) - nothing happens after the required resolution is selected.

For info: I am trying to load Sentinel 2 data.

On which operating system are you working? I assume on windows.
It is possible if you use different SNAP versions side by side that they interfere with each other.

Maybe one of the s2tbx guys (@Nicolas, @obarrilero, @jmalik) know more about it.

Could you try to open a jp2 file of the product from SNAP?
Could you try to run "opj_dum[.exe] -h (.exe if you are under windows), you can fin the openjpeg executables in the .snap/auxdata/openjpeg/4.0.0 folder of your home directory


Windows 7
I only have one version of SNAP installed at a time.

Hi Nicolas,

  1. Could not open a jp2 file in SNAP in SNAP 3.0
  2. the opj_dum[.exe does not appear in the folder stated.
    The path is: .snap\auxdata\openjpeg\openjpeg-2.1.0-win32\bin - do not have permission to run this though

When the latest version of SNAP is started the .snap\auxdata\openjpeg\4.0.1 foder is created, with the openjpeg executables inside. Your folder seems to be created by an old version of SNAP. Did you delete the .snap folder of you home directory as @marpet suggested? You might have an access right problem in this directory.

Removed 3.0 (and all other folders) and installed 4.0

This is the folder structure I get when starting SNAP for the first time:

No 4.0.1 folder?

Also tried to open a jpeg2000 file and get the same error message “Invalid OpenJpeg executables”

4.0.0 is fine, you would get 4.0.1 if you installed the latest plugin update.
This path was wrong [quote=“rjh55, post:7, topic:2875”]

Are you running Windows 7 32 bits or 64 bits?

And can you run open a command prompt in this folder and run opj_dum.exe -h?


I am running 32 bit

I just had a try with Windows XP 32 bits and things works fine in my pc. Did you try to run opj_dump.exe?


The issue seems to be related to internet security set-up and where executable files can be run from.
There is a restriction on running executable in the user directories.

Update: we got it working (Snap 4.0)