No appropriate product reader found - S3

Hi, I have just installed the latest SNAP package, with all of the appropriate toolboxes downloaded. I am having trouble loading S3 data. (ERROR - “No appropriate product reader found”).
I selected the file containing the manifest as per the instructions within the youtube video below. However, i am unable to load the data.

I am also getting a similar issue when trying to open the corresponding Level 2 imagery.

Does anyone know how to resolve this issue?
Thanks Harry.

The data folder does not end with .SEN3. I think this is the reason why SNAP can’t detect the proper reader for the data.

Thanks this solved it, turns out I was unzipping the folders wrongly removing this file ending.

Hello, I am newly starting with this and I am very excited. Unfortunately, I am getting the same error when trying to open a folder named: S3A_SR_2_LAN____20180330T105251_20180330T110250_20180330T130812_0599_029_265______SVL_O_NR_003.SEN3 or the mainfest xml.

I re-downloaded the toolbox for Sentinel 3 and followed the instruction, but I still keep getting the message that no appropriate product reader can be found. Any ideas what I can do?

S3A_SR is altimetry data. This is not support in the Sentinel toolbox.
You need to use the Altimetry Toolbox (BRAT)

Thank you very much for your fast reply. I will try that :slight_smile:

I am using SNAP7 and I still face the same problem. My folder ends with .sen3. Can you help me with this?
Cheers, Shridhar

Strange is that for the xml file only the short version is shown. Actually, it should be xfdumanifest.xml.
So please check if the file is named correctly. Alternatively, you can also drang&drop the *.SEN3 folder from the file browser onto the Product Explorer in SNAP.

2 Likes

Thank you very much, drag and drop works! :slight_smile:

Hi, I’m trying to open a Sentinel 3 product (S3A_OL_2_WFR) but I keep getting the following message, could you help me please?
I already tried to drag&drop the folder in the product’s explorer and checked the .SEN3 extension of the folder, and still the error continues

I’m not sure what’s wrong with your data but 2 things look strange.

First, all longer folder names are shortend in you path. This is unusal. Maybe you have configured Windows like this and this should not lead to problems actually.
Second observation is that you have the data on OneDrive. Maybe it is not yet fully downloaded on your local drive?
Try to copy the data to some other location and open it there

1 Like

IT WORKS! I copied the folder in the desktop and it is working now! thank you very much