No product reader found for NetCDF file

I am having a similar problem to this thread. I am running gpt on a Docker container, and I am getting the same error reading both MODIS and VIIRS L2 OC products:
Error: [NodeId: Read] No product reader found for file '/media/shareddata/projects/h2orb/raw/MODIS_L2___/tiles/'.
When I run the same graph locally on a linux box I have no trouble, it’s only in Docker. I’ve tried installing various versions of GDAL (>3.0) in the container, forcing SNAP to use its internal GDAL, tried it in SNAP 8.0 and 9.0, and tried installing libnetcdf-dev and libhdf5-serial-dev in the container. It’s only NetCDF files that are a problem, I can process Sentinel-2 and Sentinel-3 files fine with gpt within the container. The container is based on

In the end I found that the problem was to do with the file itself not being downloaded correctly within the docker container.

1 Like

Thanks for posting the solution – could help the next user who encounters a bad download.