"No product reader found" for new format files when using GPT via command line

Dear all,

I’m applying a xml graph in order to resample and subset Sentinel-2 data sets via GPT command line (Read - Resample - Subset - Write). When applying it to the “old” format (before December 6) data sets, everything works as it should, but when applying it to a bunch of new data sets, I get the following error message:
Error: [NodeId: Read] No product reader found for file C:\<…>\S2A_MSIL2A_20161212T050212_N0204_R119_T45RTL_20161212T050557.SAFE\GRANULE\L2A_T45RTL_A007695_20161212T050557\MTD_TL.xml

Furthermore, when performing the same process using the Graph Builder GUI on the new data sets, I get no error message and the job is done correctly.
I’m using the most current SNAP and s2tbx versions.

What do I need to do to solve this issue? Am I pointing to the wrong xml? I also tried to set the upper level metadata file (“MTD_MSIL2A.xml”) as input file, but that doesn’t change the result.
Many thanks in advance,

Dear Sarah,

I have just executed the same graph and it has worked properly with both metadata files. The support for the new products was included in the version 5.0 of SNAP, are you sure that you are using this one?
Could it be possible that you are using a different version for SNAP GUI and GPT?

Dear Omar,
Thank you very much for your quick reply. In fact, you are right, I run the same script on another machine with a fresh SNAP installation, and it works also with the new products. I’m sorry that I brought up this confusion.
I’m still a bit puzzled how I managed to end up with different SNAP versions for GUI and GPT, and I haven’t tracked down the old version on the system yet :-), but now I know what to do. Thanks a lot for your help!
Cheers, Sarah