No valid orbit file & Copernicus DataSpace unavailable in product library

Hi, I am getting the error no valid orbit file found when using the Apply-Orbit-File tool with Sentinel Precise (Auto Download) as the Orbit State Vectors. I have done some reading on here and see that this shouldn’t be an issue for users of SNAP 9, or if it is, I should be able to manually download from the product library. However, I have version 9.0.0 downloaded with no updates detected, and Copernicus DataSpace (from which to manually download the orbit files) is not an option as a repository in the product library. I am working with 100’s of images though so could really do with a fix that allows the orbit files to automatically be downloaded. Any help is much appreciated.


Can you provide the SNAP version displayed in the About SNAP window? (Help menu → About SNAP…)


I had the same error. I installed the latest version of snap and installed the updates. Everything going well. Thanks for feedback.

You have to update SNAP to the latest version : Help menu → Check for Updates… → install updates.

If no update is found, please check if the Update Centers are active:
ToosPluginsSettings tab :

then go to the Updates tab Check for UdatesUpdate :

There are no updates found. The update centres are active.

Restarting my computer solved the issue

At least a SNAP restart is required so that the downloaded updates get installed.