Open Files - Permission error

When I want to open (any) product within SNAP, I get following error:

After pressing “OK”, the same windows appear. By pressing again okay I get to the file selection dialog.
By every change of the directory level, the error dialog appears again twice. So it’s super cumbersome!
All the other functionalities work fine!
I run a Windows 10 machine and is managed by a central IT, but additionally, I have admin rights to install everything.

What kind of product do you try up to open?

Probably the reason for this issue is that you have an invalid shortcut on your desktop.
Similar issues have been reported before:

Even when I open snap64.exe in the bin-folder the respective error pops up

Maybe any of the installation or data folders reaches the Windows maximum? Is there any long path?

So the snap64.exe is installed on this path C:\Program Files\snap\bin.
and Cache path is on C.\User\user\.snap\var\cache
I would consider this path lengths not as long…

Can you try to run SNAP as administrator ?

same result:

I have no other idea, sorry.

I have seen similar behavior, upon starting SNAP, it finds batch files for other programs and presents a message asking what to do. It’s odd behavior, so far solved by deleting the offending file. Of concern is that these files may be essential to operation of these other programs.