'openFile' is not defined

After updating some python packages sen2cor returns an error when I try to process an image:

h5file = openFile(self._ImageDataBase, mode='a', title = str(self._resolution) + 'm bands') NameError: global name 'openFile' is not defined

Did anybody else encounter this error?


Hi unnic

I do not encounter this error but suggest to do some checks:
openFile is an intrinsic function of pyTables. In my case the following Version of pyTables is installed:

GVA0323:~ umwilm$ conda list tables

packages in environment at /Users/umwilm/anaconda:

pytables np111py27_0

Please check which Version of pyTables is installed at your site and reply.



After several reinstallations (Anaconda+sen2cor) I’m now stuck with an error described here:

I got the same problem (with a new sen2cor installation on a new machine).

After fiddling around for a long time, I apparently now “solved” it by going back to that precise pytables version which I used on another machine successfully (installed month ago). It seems that sen2cor/L2A_Tables.py of sen2cor 2.1.1 struggles with the newer pytables version meanwhile included in Anaconda2.

Here the command to downgrade pytables:

conda install pytables=

After struggling with various errors, I have now come across this particular one but I have pytables 3.2.2 and the downgrade command says version no longer exists: Package missing in current win-64 channels. Is there another way to downgrade?

I have got that bug too. The command provided by Markus works and solves the issue for me.
I then had another one : AttributeError: ‘bool’ object has no attribute ‘Size’ which was solved by removing the L2A product whose generation had failed.