Orthorectification tool doesn't find any project

Hello there,

I know a same topic was created in 2015 but I thought it was a good idea to create a new one in order to maybe have new solutions :slight_smile:

Here’s my problem:
When I try to use the tool orthorectification on any kind of data (orthographic imagery, pleiades,S2, no product can be found as you can see on the screenshot below. The product can be a subset or the original, it has no importance.

If I try to load them, SNAP tells me that’s not a valid source:

If anybody has an idea to solve the problem, it would be nice !

Thanks in advance,


The problem is that your product does not provide the information which is necessary for the orthorectification or it has the information but it is not detected by SNAP.
So I think the old post is still valid.

I thought that maybe after 2 years, we could have other possibilities.
And how do we know that the information is contained by the data ?

Import the data using the correct reader and try again.

Your data needs to provide at least the geo-location and the viewing angle in order to do the orthorectification.
Beside this, it needs to be read by SNAP correctly. So maybe, for pleiades it will not work at all. For S2 (L1C), the data is already reprojected and orthorectified, as far as I know. At least this is what I read from the PSD

@marpet, @Nicolas, @obarrilero
I tested the orthorectification tool with Sentinel-2B L1b data and I got the same error shown from the user.
Please add it as bug in the issue tracker.

Thank you,

Yes, for L1B data this should be supported by the S2 reader

I confirm the problem, the issue SIITBX-282 is created.

Thank you for answering ! It makes more senses now.

What did you mean by the “correct reader” ?

instead of opening the image directly from the orthorectification tool, import it in SNAP first via the menu > File > Import > Optical > Sentinel-2. This ensures that all metadata is read correctly.
You can then add it from the drop down menu in the tool.

Unfortunatly, still doesn’t work ! Even with your method.
I precise the image S-2 comes from the Earth Explorer of the USGS so it should have correct metadata.

Thanks anyway, I learnt something :slight_smile:

I just tried it and can confirm that selecting a product which is already loaded in SNAP doesn’t work. Could this be a bug?

As I already said, it is not possible to orthorectify S2 data. There is some implementation missing.
@Nicolas created an Issue already for the Sentinel-2 L1B data (SIITBX-282)
Sentinel-2 L1C can not be orthorectfied because they already are. Doing it again would lead to wrong results.