PALSAR 2 Interferometry in SNAP

the lines in azimuth direction are quite suspicious, and I think they were introduced during the coregistration.

Maybe you can select a higher polynomial in the Warp tab (Truncated synic) and compare

These lines are propagated into the interferogram (which looks nice), so I would invest a bit more time in their removal.

I’ve tried several different variations in the Create Stack tool. So far, the results all look pretty similar. I have also tried the suggested higher polynomial which did not seem to alter the results much.

Reminds me a bit of this case: Interferogram from Alos palsar 1.1 data

I tried co registering again, and under the warp tab, used the Bicubic Interpolation method, and then got a proper coherence image.

this looks great. Is the interferogram also correct?

Yeah, it looks good as well. See below.

I intend to document the steps I took so others can hopefully make use of my mistakes.

1 Like

nice! Please do so :+1:

I am using the following steps:

  1. Coregistration (in the warp tab, I use the bicubic interpolation method)
  2. Interferogram Creation (I also check the box for removing the topographic phase and include coherence estimation in this step, I see some people advise this as a separate step)
  3. Goldstein Phase filtering
  4. SNAPHU export
  5. SNAPHU Phase unwrapping (so far I have had success using only the DEFO method)
  6. SNAPHU import.
  7. Phase to displacement
  8. Range Doppler Terrain Correction

Hey i have been following these above mentioned steps for interferometry but I m getting error at snaphu export.I’m using ALOS 2 PALSAR2 data in snap 7.0.
Thank you

Please describe your error.

Hello sir, I have been trying for interferometry in snap software. As the steps mentioned above by the ballistic I have followed them. but I am getting an error when I perform phase unwrapping. The steps were coregistration, interferogram creation, phase filtering, and SNAPHU export. After this export, there were coherence and phase images, which were not opening in snap software. I am not sure where I have done the mistake. and the screenshots of the results ha been attached.
Thank youphtos.docx (3.9 MB)

as you are using a quad-pol product, i recommend to use the “select band” operator at the beginning and perform the workflow on HH first to test if everything works alright. The images you currently show include all polarizations, which does not make much sense at the beginning. Please check how phase quality can differ for the polarimetric bands: Effect of polarization on interferometric products

The SNAP workflow for polarimetry you described is working with single polarization images, so I recommend to repeat it with only one polarization at a time. Then your interferograms should look more typical (currently, you are displaying an RGB image of several bands).
Maybe also this tutorial helps you: Interferometry Tutorial with Radarsat-2 It was based on Radarsat-2 images, but the steps are the same for ALOS-2.

Thank you so much sir, I will surely try and attach the results as soon as I complete.

That is my mistake. I was working only with the HH band in my workflow. I will update my post.

I should be clear, I am working with only the HH band, the images I used were quad pol. I used the band subset to choose just the HH information

Hello Sir, I have been trying interferometry by using only one polarisation. I got stuck at the SNAPHU export step. When I export the image file of the unwrapped phase is missing. I am not getting what will be the reason for this. I have attached the screenshots of the processing steps. please provide me the solution for this error. Thank you.images interferometry.pdf (518.7 KB)

before you can import the unwrapped phase, you have to create it by executing snaphu.

Please check the instructions regarding snaphu in this tutorial: Sentinel-1 TOPS interferometry

Hello,
I have been trying for snaphu unwrapping. Even after following the steps from the above pdf still it showing the error and phase unwrappin is a problem. I am not getting whther there is problem with the system im using or software. please suggest something so that i can try.

please help us understand your case:

  1. were you able to execute snaphu correctly?
  2. has the unw_phase…img file been created sucessfully?
  3. please specify “still it is showing the error”

SNAPHU is very particular in that you HAVE to set up the inputs correctly. This can be a bit hard to follow at times if you have not been diligent in setting up how you write your new data.

This is not perfect, but it is a more detailed workflow of the steps I took.
PALSAR 2 InSAR Workflow in SNAP.docx (855.7 KB)

1 Like