Path does not exist; '\L2A_Process.bat' variable SEN2COR_BIN is not set

Please help. I was trying to run sen2cor on one of my images and SNAP is giving me this error message

Path does not exist; ‘\L2A_Process.bat’
variable SEN2COR_BIN is not set

maybe you should check and set it manually: Sen2cor 2.4.0 on SNAP 6.0

1 Like

the answer is in this “installation manual” I madehow to use Sen2Cor within SNAP-1.rtf (11.1 KB)
Good luck

1 Like

Thank you very much, it worked… yippeee

Great! I am glad it worked and to have been helpful

I managed to run it on some of my images and it completed within 30 to 60 minutes each image. The one I am correcting now has been running since Thursday last week, and its been 3 days, 22 hours. Is that still fair?

is it the same area of one with more topography? More clouds maybe?
Otherwise I would restart it.

Absolutely not; all depends of the computer of course. On a pretty fast Windows PC with much RAM, it takes at most 20 minutes at a 10-m resolution. Your system is looping around indefinitely. If you’re running Windows, stop the process in Task Manager and restart the program or even restart the computer. By precaution I restart SNAP (and Sen2Cor) after each run. Since it restarts quickly it’s not a nuisance.

1 Like

Thank you very much. restarting SNAP/Computer works.

When I follow this path and run sen2cor on L1C the process runs but I don’t find any processed files in my GRANULE folder.