Phase Unwrapping

“snaphu v1.4.2
unable to read configuration file snaphu.conf”
I get this response from the command terminal when unwrapping. Who can help me?

1 Like

first you ha to give the path for the configure file:

  1. copy the folder path by right clicing properties, copy the path
    2)write in the terminal: cd and paste the path here
    after you can copy this snaphu -f snaphu.conf…
    and its begins to load

Hi? Thank you for your kind advice. I still get the same results. Could you elaborate further.

okay, here is a pdf, with printscreens :smile:
snaphu.pdf (325.8 KB)

1 Like

Thank you. It finally works. :smiley: But on a sad note, it takes for ever.
It has been on the line “Setting up data structures for cs2 MCF solver” since morning.
Should i wait?
In the first attempt it responded with “Killed” :sweat:

I think you should create a really small subset, like 10km x10 km. For me it was the solution.

1 Like

After allowing the process to continue overnight this is the response i got.
What could be wrong

I made it!! Thank you so much.

1 Like

the other problem i have experienced is that on comparing with STRM 30 meter DEM my ERS1 ERS2 derived DEM has a root mean square error of 254! Some heights have low error others so high in error. What could be the problem?

Do you think that this is the solution for all cases? I have 16 GB, and more than 300 GB memory, as well as I tried less than 10 Km subset, but unfortunately this is not the solution.

Can you not unwrap any interferograms, even easy cases? Your screenshot showed that SNAPHU crashed with a segmentation fault so obviously something is seriously wrong.

Ok, but this is a new answer from you, even you answered me before two different answers, anyhow, would you please to give me the right series that I could follow, and please do not say the tutorial because I have all tutorials starting from nest to snap, as well as during my PhD I used GAMMA software. so I think you are keen and I’m also to find out the reason of this matter, so please again give me in one line the right series I could follow reaching the wanted results.

Are you sure that your installation of SNAPHU on your system in faultless?

I believe yes and to check the snaphu, here you could find that it is running without any problem,

also I increased the RAM of VM.

Googling SNAPHU segmentation fault finds this:

Not sure if it has anything to do with your issue though.

I found that the the snaphu was available through the aptitude repository, I installed from there and now it works despite of the size of the scene, also to take in account what it is mentioned by Marcus,

can you send me this link please

If you double click on /etc/apt/sources.list, it opens a GUI interface with a wizard for adding repositories. There is a checkbox where you can enable and disable entries (e.g., to allow use of a new entry only when updating some “foreign” repository software), and entries can be deleted. It also creates a backup called in the same directory. If you want extra protection, you can always make a copy of the original file yourself before changing it. So there isn’t much risk of messing up the file if you are going the script route just for that reason

in my opinion (but not sure, so please correct me if I’m wrong) the SRTM is a surface modell (DSM), which means it contains for example buildings, plants. So it could be the reason.
Anyway I’m interested in how did you calculate root mean square error? Is it a built-in algorithm in SNAP? or I also would like to check it! Thanks

What i did is i created 20000 random points in ArcMAP and attached the heights values from both the SRTM and ERS derived model. I then used excel to calculate the RMSE using the generic formula.

1 Like