POE ORB Download..it's possible with SNAP?

Hi guys,
I should have to download POE orbit files for PS analysis. My colleague recommended me the script “Sentinel-1 POE orbit download” in python (see the link: https://github.com/insarwxw/Sentinel-1_POE_orbit_download). When I lunched it in Python IDLE, Python didn’t find the module “numpy as np” (you can see below the screenshots). I didn’t modify the script, I only opened the file and clicked run. So I installed the variable in these way:
“pip install numpy
conda install numpy”
but it didn’t fix the bug…

Therefore, it’s possible with SNAP download POE orb Sentinel-1 files?

Thank you for any response!

You don’t mention your OS, but from the screen image it looks like Windows. The first line of the script is a linux “hashbang” line that tells the linux shell to use “python3”. You could try using python3 -m pip install numpy or pip3 install numpy, but Windows apps often install “private” Python, so you may have multiple installations of Python3 (the long list of culprits includes Visual Studio and QGIS).

I have MacOS Catalina

I tried -p install numpy and pip3 install numpy, but both didn’t work. Compared a syntax error message.

I should have recognized macOS from the “on darwin”.

Apple provides a stripped down Python that is usedsho for system scripts, but users are advised to install Python for use with SNAP. Anaconda Python should be fine, but extra steps are needed to make sure that it is used by applications. When you install Anaconda Python you should be given the option to add lines to your startup script (~/.zshrc). You may have to logout and back in for those lines to take effect. You should see “Anaconda” line that gives the Python version.

You seem to be editing the Python script to add the install commands. Those commands are normally run in the macOS Terminal, but assuming the conda install numpy command worked, it may just be a matter of ensuring that the download script uses Anaconda python. The usage example for the script is intended to be run in a Terminal. If your startup script wasn’t configured, you can manually start the Anaconda environment in a Terminal by entering

source ~/anaconda3/bin/activate

Using this, python3 --version should mention Anaconda. You update the startup script (assuming you are using zsh) after running the above line with:

conda init zsh


  1. Install Anaconda,
  2. Set Python 3 on Anaconda,
  3. Start Anaconda in a Terminal with code “source ~/anaconda3/bin/activate”
  4. Open script and update the startup with “conda init zsh”

It’s correctly?

The Anaconda installer should have presented the option to edit the zsh startup script, so step 1 is enough unless you omit the update to the startup script (or the offer wasn’t presented for some reason). The changes to the startup script add the source ~/anaconda3/bin/activate so you don’t have to enter that again, but if you had a terminal session running you need to restart it so it uses the updated startup script. When Anaconda3 is “activated”, you should see (base) at the start of the terminal prompt.

Now that I think of it, I can’t recall if Anaconda3 provides a “python3” or just “python”. In a terminal with Anaconda3 activated, “python --version” should give a 3.x.y version and “Anaconda” and “python3 --version” should give identical results. If “python3 --version” is different, the script will run with the wrong Python. Since you installed numpy with conda, you should be able to run the
download script in a terminal as follows:

(base) user@host %  python ~/Downloads/S1_POE_Orbit_Download.py raw_list.txt