Polsarpro 6.0 error

When launching Polsar pro Biomass edition program, it does not find the exe. Does anyone else have this problem?

Do you get any error message?

PolSARpro is not started by an exe but a tcl-file. It stands or tool command language.
Try opening it from the installation folder

grafik

If your system cannot execute it, you need to install TCL-TK: https://www.activestate.com/products/activetcl/downloads/

This is described in the ReadMe file: https://www.ietr.fr/polsarpro-bio/Win64/README_PolSARpro_v6.0_Biomass_Edition_Win64_Installation_Procedure.pdf

Thank you very much, He managed to install the program.

Still I can not get to the menu to work with UAVSAR images in GRD format. any ideas?

I just downloaded this granule at ASF Vertex and it works well
UA_munich_19417_15088_002_150605_L090_CX_01

grafik

grafik

Any questions related to PolSARpro shall be now posted here: https://forum.step.esa.int/c/PolSARpro

Hi this was very helpful. I can complete through the H/A/Alpha Classification step and get my Anisotropy, Entropy, and alpha files, but I cannot figure out how you created the entropy vs alpha graph. Was that created in PolSARpro? How was it created? Thank you for your help.

you open any of these bands and then select the plot tool from the Menu:

Thank you for the help. From what I can find the supplied image provided appears to be in SNAP Desktop and not PolSARpro. Is that correct? I have been able to navigate in SNAP to the H-a Alpha Plot as shown but cannot seem to get the alpha and entropy files to plot. I have tried using the H-Alpha Plot button on the main desktop interface and the refresh button in the plot itself is faded out. How can I get my two files to plot within this tool? Thanks in advance for the help.

Hi Andreas,
Is there any more information you can supply on creating the H-a Alpha plot? Within PolSARpro I cannot find this toolbar. Thank you for your help.

in my example I was referring to SNAP, yes (sorry, I somehow overlooked your post from 12 days ago)

To display the plot in SNAP, you need to calculate alpha and entropy with the “Polarimetric Decomposition” tool first. Select H-A-Alpha Quad Pol Decomposition in the second tab. This creates a raster with Entropy, Anisotropy and Alpha which you an then select for the Plot tool.

You can try (as a work-around, no guarantee) to stack your existing entropy and alpha rasters and rename the bands accordingly (Entropy and Alpha) and try if SNAP takes it as an input. Otherwise I recommend deriving them directly in SNAP.

Hi Andreas,
Thank you for your help. This makes a lot more sense. I am running into one problem. What file should I be placing into the H-A-Alpha Quad Pol Decomposition tool? I am working with UAVSAR data and the tool will not accept the raw UAVSAR data or the PolSARpro derived files. I continued to get the the error the file is not readable or that it needs to be a SAR file. What specific file do I need to put into the tool to generate the plot? This tool woks with UAVSAR data correct?

Thanks for your continued help.

I don’t know if SNAP supports UAVSAR, sorry.

Hi everyone.
I have installed Polsar pro v6 and run it.
But the software doesn’t work and I got an error message as follows. What goes wrong and how to solve the problem?
Thank you.!

Error%20Capture|690x415

could you please re-upload the error message and tell us at which step it occurs?

That rather looks loke a compiling or installation error. Have you tried reinstalling it again?

Hello Abraun !!!

I am also getting the same error in ubuntu 16.04. I just followed the instructions and tried using wish filename.tcl. But the same error (can’t find package img) crops up everytime.Kindly help.

Hi
This not a compiling or installing error.
It just means that the Img package is missing in the tcl kernel which is installed on the linux machine
In the linux automatic installation procedure we propose, it is asked to execute the following command:

[user]:> sudo apt-get install libtk-img iwidgets4 bwidget

libtk-img corresponds to the missing Img package

Hope this will help
Regards

Hi

When you process the H/A/Alpha classification with PolSARpro (see the screencopy of the ABraun reply dated May 7) the entropy-alpha plot is automatically generated (as it can be seen also of the screencopies of the same reply).
Another way to produce a scatter plot with PolSARpro is to use the “display” menu then the “scatter plot” functionality.
Hope this will help
Regards

I have installed libtk-img through the command line as per the command. The error still persists.Kindly help.