PolSARpro installation error - Ubuntu

Dear all,

I’m having some difficulties installing PolSARpro v6.0 Biomass Edition on my Ubuntu 22.04 64-bit system. I downloaded the PolSARpro zip file from https://ietr-lab.univ-rennes1.fr/polsarpro-bio/ and followed the instructions for a Linux installation (installing all the necessary packages first). During the installation I notice a lot of collect2: error: ld returned 1 exit status and “Multiple definition of XXX” “first defined here” errors messages in the outputs (screen shots below). After the install is completed I do not end up with an icon on the desktop.

When I run PolSARpro using the wish command the program window pop up (screen shot below), but when I press Enter I get an error message (screen shot below). As far as I can tell, the tools folder in Soft/bin is empty. I’ve tried reinstalling and tested with using sudo/not sudo, but still the error persists. Has anyone else experienced this and know how I can fix this issue?

Best regards,
Ingrid

PS. Apologies for the similar posts. I wanted to edit the previous post to add the error messages from the installation for clarity and in case others get the same messages, but it was not possible to edit my previous post, so I decided to make a new post instead.




error