PolSARpro v.6 Missing operand Error

Dear PolSARpro team,

I am getting this error below, how can i fix this.

missing operand at @
in expression “round(150 * @)”
missing operand at @
in expression “round(150 * @)”
(parsing expression “round(150 * )”)
invoked from within
“expr round($geowidgetheight * $WidgetSizeRatioHeight)”
(procedure “WmTransient” line 71)
invoked from within
“WmTransient .top7 $PSPTopLevel”
(“eval” body line 452)
invoked from within
“eval {global PSPTopLevel PSPBiomassFunction DataDirInit DataDir DataDirChannel1 DataDirChannel2 ScreenRatio
global OffsetLig OffsetCol FinalNlig Final…”
(“uplevel” body line 1)
invoked from within
“uplevel #0 [list eval $cmd]”
(procedure “vTcl:DoCmdOption” line 16)
invoked from within
“vTcl:DoCmdOption .top00.fra217.but218 {global PSPTopLevel PSPBiomassFunction DataDirInit DataDir DataDirChannel1 DataDirChannel2 ScreenRatio
global Of…”
invoked from within
“.top00.fra217.but218 invoke”
(“uplevel” body line 1)
invoked from within
“uplevel #0 [list $w invoke]”
(procedure “tk::ButtonUp” line 22)
invoked from within
“tk::ButtonUp .top00.fra217.but218”
(command bound to event)

Hi, I had the same Problem with Win10. But I changed in POLSARPRO > Help > PolSARPro v.6 (Biomass Edition) configuration > PolSARPro SW configuration the “Widget Size / Screen Adjust” with RUN. In the Dialog window you can change the Widget Size Ratio. After you cab Exit and Save the new one. After them I had the problem that PolSARPro didn’t start and got the same error.

I have researched in my directories and found in the directory C:\Username\Application Data\PolSARpro-Bio_6.0.3\Config a file called “PolSARproConfiguration.txt”. In this file are the new settings of the Widget Size / Screen Adjust.

I did set the parameters to the original values and after them PolSARPro works again.
PolSARproConfiguration.txt (70 Bytes)