Polygon drawing tool

Hi everyone,

I have been struggling with something that looks like a bug in SNAP polygon drawing tool. I need to creat masks but I can only draw rectangular and elliptical polygons, while the polygon drawing tool does not show me any polygon if I try to draw it.
In addition, when I create the vector in “new vector data container” the polygon is added in the vector folder while it is not shown in the mask manager. There is not error shown and if I try to import data in .shp that contain polygons like those they are not shown in the folder, so I cannot import auxdata neither.
In the picture I show better my issue

Hoping you can help me, and thank you for your patience! :slight_smile:

Hi Luca,

I haven’t heard about this problem before.
I just tried it on a S1 GRD product and it worked for me.
Does this Problem happen on every product? Can you try with another product type? Maybe not a SAR product.
Are you using the latest version? SNAP 8 with latest updates?
Maybe restating SNAP can fix this?

Thanks for the answer.

Yes, I tried with another product (SLSTR) and it does not work. I tried to disinstall and reinstall SNAP through a different browser but it gives me the same error. It’s very weird because it does not recognise only that type of polygon

just thinking aloud: On my case the mask only occurs when I save, close and re-open the product. So maybe the display of vectors is just deactivated in the layer manager?

I can confirm that the polygon tool in fully updated SNAP sometimes doesn’t display anything as you draw the polygon, but it does appear after you double-click to complete the polygon. This happens using Windows 10 Pro with integrated graphics (Intel Graphics 620) and the Intel Corporation Display driver updated this week. I could reproduce it on another Windows system (same model, but running Windows 10 Enterprise, a year newer and using Intel Corporation Display Fedora 33 linux using Wayland on Intel 630 integrated graphics also has the problem.


Thank you all for the help! It was so kind from you.
In the end I was able to draw polygons, still don’t know how but it worked.

1 Like