Problem Importing Shapefile into Raster Previewed

Hi there

I have a bit problem. I want to import shapefile (Point) that have been created in ArcMap/ArcGIS, in SNAP using familiar window (Layer Manager) Add Layer (ESRI Shapefile). The shapefile doesn’t previewed on raster after finishing importing although my raster and shapefile in same coordinate system.

Can anyone give me a direct step by step to complete importing my data correctly.

ArcGIS screen views can reproject the displayed data without changing the original coordinate system of the data. Quoting ArcGIS Coordinate Systems and Projections:

ArcGIS Pro reprojects data on the fly so any data you add to a map adopts the coordinate system definition of the first layer added. As long as the first layer added has its coordinate system correctly defined, all other data with correct coordinate system information reprojects on the fly to the coordinate system of the map. This approach facilitates exploring and mapping data, but it should not be used for analysis or editing, because it can lead to inaccuracies from misaligned data among layers. Data is also slower to draw when it is projected on the fly. If you intend to perform analysis or edit the data, first project it into a consistent coordinate system shared by all your layers. This creates a new version of your data.

If that is your situation you could try reprojecting the shapefile from the data coordinate system to the one your want in SNAP, e.g., using GDAL’s ogr2ogr. You might also consider using WKT instead of a shapefile.

Thank you gnwii

I re-projected my data and same problem still exists, and I have no experience for doing with GDALs, I ask if there another method to solve this matter.

Thanks for help

Have you tried “Import / Vector Data / ESRI Shapefile” from the menu instead?
The model coordinates look like UTM CRS. I think you product should be in the same CRS.

Please try to solect the raster product, then add the shapefile via the menu > Vector > Import > ESRI Shapefile

Edit: Way too late, I did not see marpet’s answer… :sweat_smile:

1 Like

Dear @marpet, @ABraun
I tried importing vector from menu>vector>import>ESRI Shapefile, It is worked at least, but I ask why it doesn’t work from layer manger.
Generally, I’m sincerely thank you for your clarification.

Without knowing your shapefile it is difficult to say why it is not working in the layer manager. my guess is that it is related to the CRS.
Maybe you can provide the shapefile?

Thank you Mr. @marpet. My Shapefile and Raster in same coordinate system UTM WGS-84 Zone 38N. with the the coordinate system EPSG: 32638-WGS 84/UTM zone 38.

Here I’m uploaded the two Well Known Text for the same coordinate system UTM from the database for the two software (SNAP, ArcMap/ArcGIS ver.10.4).

My data attachments below

WKT_SNAP.txt (798 Bytes)
WKT_ArcGIS.txt (502 Bytes)

Those look similar as they should.
And the Shapefile, can you upload it too?

Hello Mr. Marpet thanks a lot for follow my post.
It seems the value of Angular Unit different slightly (0.017453292519943295, 0.0174532925199433) between two software SNAP and ArcGIS respectively.
Do yo think that is the cause for difference reading the shapefile in SNAP Environment.?

Here my shapefile in attachments.

Station.rar (1.7 KB)

No, this is just a rounding issue. The values are same enough.
Thanks for the shapefile.

Indeed there must be something wrong in SNAP. Probably it doesn’t handle the projection correct. I’ve added a ticket to our issue database.

Maybe you can convert from UTM to WGS84/plate caree. I guess this would work better.

Dear Mr. @marpet
Oh, ok with pleasure, I see your link in forum. The WGS84 is same to UTM failed to add shapefile to Raster in SNAP from Layer Manager Window. I added my shapefile from menu>vector>import>ESRI Shapefile. Thank you very much.