Problem in Sen2Cor installation on Windows system

While installing Sen2 Cor, the following error is shown:
D:\Sen2Cor-02.09.00-win64\Sen2Cor-02.09.00-win64>L2A_Process.bat -help
usage: [-h] [–mode MODE] [–resolution {10,20,60}]
[–datastrip DATASTRIP] [–tile TILE]
[–output_dir OUTPUT_DIR] [–work_dir WORK_DIR]
[–img_database_dir IMG_DATABASE_DIR]
[–res_database_dir RES_DATABASE_DIR]
[–processing_centre PROCESSING_CENTRE]
[–archiving_centre ARCHIVING_CENTRE]
[–processing_baseline PROCESSING_BASELINE] [–raw]
[–tif] [–sc_only] [–cr_only] [–debug]
input_dir error: argument -h/–help: ignored explicit argument ‘elp’

you have to add --h for the parameters, not --help
The message indicates that it was installed correctly. Please try applying it to a L1C folder and see what happens.

Thank you ABraun. The issue is now resolved. In manual it is written to type ‘L2A_Process.bat -help’, but when I typed, ‘L2A_Process.bat --help’, it worked without error. Earlier even if I had ignored this error and proceeded to use it for atmospheric correction, there was an error, and some files were empty in the resulting BOA product folder. The error was resolved with the successful processing of generating the BOA product by reducing the path of the input files (L1C).

You’re right. Probably the manual needs some adjustments here…
Glad to hear it worked in the end.

With Unicode, there are multiple “look-alike” symbols (math minus, dash, em-dash as well as opening and closing quotes). Web pages, editors, and/or viewers often “improve” the original text by substituting an em-dash for a double dash or changing quote marks.