Problem in Snaphu Import section

Hi all
I have a problem in Snaphu Import step. I did the export step (created Phase/Co files in img/hdr format) and then successfully generated unwrapping file (UnwPhase in img/hdr format) with SNAPHU.
But I do not know which file must be inserted in first tab of “Snaphu Import” (1-read phase).
When I insert the Phase file created in the export step, I receive following massage:
“3-SnaphuImport: SnaphuImportOP requires at least one product with InSAR metadata”
When I insert the filtered InSAR Phase (created in Goldstein phase filtering step) in dim format, I face following massage: “Operator ‘SnaphuImportOP’: source product not found”.
Actually I have problem with adding metadata of phase file to UnwPhase file.
Thanks for your guidance.

4 Likes

I faced the same problem. I also managed to do the export step and genetare the unwrapped file but I do not know how to import the file. Unfortunately I cannot insert the file without any failure message. It would be really important to handle the problem as soon as possible because I am doing a research at university.
Thanking you in advance.

1 Like

I had the same problem and until now I didn’t find any solution for this issue. It doesn’t matter what I do. The steps I followed are exactly the same of the Sentinel-1A tutorial.

I could get around this problem. I uninstalled SNAP 2 beta version 5 and used previous version, I mean NEST 5.1.
You can follow up the procedures step by step based on the following tutorial:
https://saredu.dlr.de/unit/insar_deformation
You must insert metadata of phase image into the unwrap image by generic binary tool.

regards,

1 Like

Thank you Mehdi. That was really helpful. It´s working properly in NEST 5.1.

My best regards,

Hello Mehdi. I’m having another problem now. When I go to convert the SAR architecture to terrain in NEST it says that the product is already geographically projected, which is obvious, bu I can not earease the WGS 84 projection in order to do the Range Doppler Terrain Correction. Did you have the same problem?

Hello guys,

I have the same problem with importing in SNAP and simillar error messages as Mehdi. So i tried to proceed it in NEST 5.1 according to the mentioned tutorial and I face following error mesage: ‘3-Snaphu Import java.lang.NullpointerException’ … do youn know what I am doing wrong?

Thank you

Well. The Unwrapped phase is supposed to be joined together with the phase. I was facing the problem with SNAP then I decided to use the Sentinel 1 Toolbox (1.1.1; WIn 64bis). It worked but you should use the metadata of the phase that you used in the SNAPHU exporting (the input data in .dim format). I used that as the phase and then the SNAPHU unwrapped phase. It worked.

1 Like

Hello,
I am trying to use SNAPHU in NEST 5.1 to unwrap an interferogram created in SNAP however I get an error message saying “NullPointerException”, can you advise on how you managed to unwrap using SNAPHU in NEST 5.1? Did you run coherence estimate to obtain a coherence band?
Thanks!

I had the same problem. I found the solution by doing the entire process in Sentinel 1 toolbox (1.1.1). I guess it´s not possible to use processed data generated in SNAP on NEST 5.1. You should try that again by using Sentinel 1 toolbox. In this case the snaphu exported data would be the same, therefore you might use the unwrapped phase that you have already created.

1 Like

Alright thanks, i just finished downloading sentinel 1 toolbox. I will see how it goes.

In addition, for those who have problems on unwrapping in SNAPHU, there is a very intuitive and interactive tool in MatLab, that can handle the unwrapping. The code can be download on the following link: http://www.mathworks.com/matlabcentral/fileexchange/22504-2d-phase-unwrapping-algorithms/content/GoldsteinUnwrap2D.m

1 Like

I could not find this generic binary tool in the Sentinel 1 toolbox, I don’t see this

File > Import Raster Data >Common File Formats > Generic Binary

Also, I tried to use the alternate method described in slide #36 using Snaphu import Graph, and it still says Snaphu import requires at least one file with inSAR metadata.

“Generic Binary” option dose not exist in SNAP 2, you can find it in NEST 5.1. version. You must install NEST 5.1. then you can find that.

Thanks a lot Mehdi, I will try that.

So I inserted metadata of phase image into the unwrap image by generic binary tool and saved it as BEAM-DIMAP format.

Now I trying to import it by Snaphuimport:
When i try in SNAP: it gives me error as if I have not updated the metadata saying import requires at least one product with inSSAR metadata
When I try with NEST, it gives me the error java.lang.NullPointerException

For Read 1: I have phase file as BEAM-DIMAP
For Read 2: I have unwrapped image as BEAM-DIMAP

I am not sure what I am missing!

1 Like

Hey Mehdi,
Which operating system did you use to do snaphu phase unwrapping using cygwin?
I am attempting it but it does not fully execute, it runs out of memory and uses up all of my 16GB RAM halfway through the processing. I tried increasing the size of my Virtual Memory and now the process has been running for 2 days now stuck at “setting up data structures for cs2 MCF solver”.

Did you encounter any of this errors?

Hi
I usually use Windows and sometimes Linux. But I think your problem is not related to OS directly, your problem is lack of enough RAM for processing. As far as I know, there are tow ways to overcome this problem 1)upgrade your system (I mean RAM) 2)If you use a complete scene of radar data, you should use a part of scene and crop the sections of data that dose not have any role in your case study (select a subset image).
I hope that it would be helpful…

Alright thanks,
I guess I have to update my RAM because I created a subset yesterday and ran the same procedure on a different computer with the same sized RAM as the first and the processing is still running, just like the first one.