Problem running SNAP in IntelliJ IDEA


I’m trying to run SNAP Desktop using IntelliJ IDEA but i keep getting this error message:

INFO: class org.esa.snap.nbexec.Launcher: 43 module patch(es) found for pattern C:\Users\jorgej1\Snap_git\snap-engine$\target\classes
java.lang.IllegalArgumentException: Malformed branding token: ${branding.token}
at org.openide.util.NbBundle.setBranding(
at org.netbeans.core.startup.CLIOptions.cli(
at org.netbeans.core.startup.CLIOptions.cli(
at org.netbeans.CLIHandler.notifyHandlers(
at org.netbeans.CLIHandler.initialize(
at org.netbeans.CLIHandler.initialize(
at org.netbeans.MainImpl.execute(
at org.netbeans.MainImpl.main(
at org.netbeans.Main.main(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.esa.snap.nbexec.Launcher.runMain(
at org.esa.snap.nbexec.Launcher.main(

I have been following this guide Guide.
I have errors in the SNAP Desktop Project dependencies, but this is warned in the above mentiones guide.
Maybe is relevant that i made the Maven install skipping the tests becouse i had one in snap-engine…

I also have tried to reimport all maven projects and download sources again.

Im using winows 10.

Any idea what can be the problem?

EDIT: problem solved after running maven from IntelliJ IDEA


I have the same problem since this morning. I can run any process with SNAP . I get messages as: A problem occured during the target product processing.
Message: java.lang.IllegalStateException …

Is someone knows about the problem with SNAP ?

Hello, does not seem to be the same problem i had… But you should try to update either SNAP and its toolboxes, sometimes solves problems.