Problem when unwrapping InSAR


I created an interferogram and I have problems when trying to unwrap it utilising SNAPHU plug in.

When im Exporting the interferogram the file is created too quickly and i can’t input the Exported Interferogram SnapHU-> Unwrapping after because the file doesn’t appear (example: Screenshot - fc7a2bde4890bf9518b1078840f7cd9b - Gyazo).
Example of file size (Screenshot - 07fdb07de35e8147548422d1a730f7b9 - Gyazo)

I even tried to do the Export operation multiple times with no sucess (Screenshot - a6cc7646446b2ae6ba593623065dfba7 - Gyazo)

When importing: Screenshot - 9101174cba3c3b8ee00eda543c63da30 - Gyazo

Any solutions to this please?


the second screenshot shows that the img of the unwrapped interferogram is missing - that indicates that the unwrapping has not been performed, so there is nothing to import.

You can try to run snaphu from the command line - it is easy and error-proof.

Thanks a lot for the suggestion. I download the snaphu and did the unwrapping in the cmd line. Screenshot - cd94194154a94be84228e18dc2847372 - Gyazo

It seems that it worked! Screenshot - 282ebd84cbd09de80872041e9e9f4e5b - Gyazo

But now i have another error when opening: Screenshot - ca5c7cb24dfabd1f6da552ef3443dcb7 - Gyazo

Do you know how to solve this? Thank you

good job on running it in the command line. However, as long as there is no img file produced (starting with UnwPhase…) the proess has not finished. SNAP needs an img and the hdr file (similar to the Phase and coherence file pairs).

I think i did it! However the results seem a bit weird… Screenshot - 60f0c8f15a2684feb443ff6fdcb50903 - Gyazo
Original interferogram: Screenshot - 5f49b7954a078fcfe1f6e48d67a24e5d - Gyazo

I already increased the tiles output size from 10->20. Maybe i need to increase more? Thanks


I didn’t notice that the default Row and column overlap was set to 0 in the SNAPHu export. In a tutorial they set to 200 and i got this result: Screenshot - 246416658978663dca8776edc6fa2a56 - Gyazo

Looks way better! You might try to Filter out low coherence pixels before phase unwrapping

I did that, the result: Screenshot - 4e610a29155c0baa85322c2522fc5c9d - Gyazo

I think it looks pretty good, however when creating the interferogram I couldn’t do one step named (Topographic Phase Removal). Is it really necessary?

Do you know how to remove that green fill border on the right with no information?

Thank you

that depends on what you want to do - analyzing displacement or deriving a DEM?

Check its pixel value and then enter it as a NoData value in the band properties.

It’s for displacement analysis!

Ok thanks Will do that to remove the green fill


then you have to remove it. You can include this in the interferogram formation step (there is a checkbox for it).

Hello! sorry for getting back to you

I did that Nodata step:

I first checked the pixel info: Screenshot - 47f8b61255942ecbf431d3aeda174d85 - Gyazo
Then went into the band properties: Screenshot - 7a3fac5248fa4216521e8efd379fc64e - Gyazo

And It still doesn’t go away. Any tips? Thanks!


SOLVED! I imported the coherence band from the previous step in band maths and then in displacement raster → properties → valid pixel expression → edit → coherence_VV > 0


good job! :+1:


Could you help me with one more thing please?

I noticed that the default color scheme for displacement maps is a bit weird so I’m trying to update it to make it clearer.

Im using this tutorial Unwrapped Interferograms: Creating a Deformation Map – ASF

and i reached this part: 5. Select the Basic view in the top left region of the tab. Select great_circle from the colour ramp options, and click the Range from Data button.

However in my color ramp options i don’t have “great circle” option. Do you know where I can get it?

Thank you!

You can export the color scheme of any product in the color manipulation tab and then load it again into other bands.