Problem with configuring python to use the SNAP-Python interface on a Mac

Any time I try to follow the instructions that are on the website I have an error when it comes to the snappy config and python executable. I have the proper file path according to “which python” in command line but it will say that it doesn’t exist/ isn’t defined.

Thank you.

Hi @remuench, I met the same time when using SNAP on a windows10 system. Have you solved it?

Can you show the command line output of ‘which python’ and snappy-config ?
Is it possible that ‘which python’ points to a symbolic-link? Maybe we don’t follow this link properly?
And you followed the instructions on this page?

Hi,@marpet, when I used Sen2cor in SNAP, it prompted that 'Path does not exist:‘python’. I’ve tried as the page you provided above, but it didn’t work. After I restarted the laptop and retried,it still prompted that. Could you give me some hints? Thank you in advance.

Sen2Cor does not use the same settings as snappy does. In order to get sen2cor running you have to follow the installation instruction which you find in the Software User Manual. You can get it here:
If you still encounter problems, please ask in the s2tbx/sen2cor category.

@marpet So I realized that it was actually an issue because I am running parallels and my python.exe was considered a parallels application so once I ran the config through the windows side I was able to get it configured. Now I’m having issues with being able to use snappy in the standalone python I keep getting this error WindowsError: [Error 193] %1 is not a valid Win32 application

Do you mix 32 bit with 64 bit? Maybe python/(SNAP)Java/OS have different 'Bit’ness?
Which call prints the error message?

I have a similar problem on Mac and appreciate your help. I inserted the correct python path during SNAP installation as outlined here:

But it didn’t work. Now I am trying the snappy-conf and I get the following error.

I am using Python 3.4, and the path is to a conda env python that I created for this particular application.


I’m not sure, but I think this could be related to the problem reported here:

I assume that you are using SNAP 5 and have updated the modules already.
There is an issue in the configuration script in snap-python 5.0.
You can work around if you use the current SNAP 6 preview version. There this issue is fixed.
Or you make a clean install of SNAP 5 and configure python before updating the modules. But I would suggest using the preview version.

Also, the content of the snappyutil.log file might be helpful here.