Problem with loading screen for S-1 Back Geocoding

It almost worked, I used STRM 1Sec Grid and STRM 1Sec HGT, and the process finished, but I have found another problem.

In the stack product I have two Intensity files, but the intensity file for slave image when I want to visualize it doesnt show information. This is happening with many stacks.

As you can see in this picture I an visualize master image, but…

In this picture with intensity file of slave image I can’t visualize it.

Then this is happening with many stacks, and when I try to create an interferogram this shows in the phase image this

I tried to do it with other DEM and the problem persists.

an empty product means that the coregistration failed.
Can you please check if both input products contain valid data before BackGeocoding?

First, how can I check that?

Second, I am goint to show that both files show the data until orbit file step.

Both images in orbit file are ok.

I don’t know another way to check valid data, can you teach me?

I changed the order of corregistration, I changed master image and slave image, curiously when I apply Back geocoding with SRTM 1Sec curiously always slave image doesnt show the data, but that slave image was the master image in another process that I did, and when that image was master the data was shown, so the problem is with slave image data in the Back Geocoding.

you can create a RGB image after BackGeocoding, please have a look at page 8-9 in this tutorial: Sentinel-1 TOPS interferometry

It didn’t work, red+green for master image, and blue for slave image, but it failled.

If your want to use SRTM 3Sec before the next update, please check the work around here: Gpt sentinel-1 back-geocoding error

I have found this link, I have downloaded it, but I don’t know if I open it in snap, I don’t know how, it could solve my problem?

The address I have sent you is to make sure that the SRTM 3Sec data is correctly downloaded, because this has changed recently. So you don’t access the page to download it yourself.

As described here, you go to your snap installation directory and find the file called “” inside the ect folder

Open this file with a text editor and go to line

and replace it by

Save the file and close it. Next time SNAP searches for SRTM 3Sec data, it will access this source instead of the old one. The BackGeocoding step should then work again.
This will be fixed with the next update, but if you want to have SRTM 3Sec data automatically downloaded before you can change it yourself as described above.

Another thing is to make sure that SNAP is generally allowed to access online resources. Please make sure that port 443 is open in your firewall settings. How to Open a Port on Windows Firewall
Windows and Mac: How to open ports in your firewall

I’d like to know why with SRTM 1Sec slave image data is empty.

if it fails with both SRTMs it might really be the firewall.

I followed firewall steps, and the problem persists. I think that I have to wait the updates for SRTM 3Sec, for windows 10.

instead of auto download, you can also manually download a DEM and use it as an external DEM in this step

How can I import an external DEM in snap for windows 10?

Please use the search function of this forum:



Can I use GMTED2010 DEM?. I am going to reproject it in WGS84 coordinates system.

yes, as long as it entirely covers your data and you store it as GeoTiff (in WGS84) you can use any elevation data as external DEM.

Ok, I am going to check the results, I hope this works.


This is the file:

When I use external DEM this appears

And the process stops.

I used this another file:
The loading process worked. I am going to check if slave image data appears.

The rseult is the same, slave image didnt appear

I dont know what to do now, I changed dem and it didnt work.

Can I ask you a favor, I dont know if it is possible but I would like that you can make the same process with same pair to know if the problem is my computer, the images or the software.
In the case if you can do that these are the images:

For both images I made top-split: The split is IW3 Burst 4.
Are in south of Colombia and North of Ecuador.

Thank you.