Problem with subset -> Idepix with MERIS 4th reprocessing


I’m having an issue with applying Idepix to the new MERIS 4th reprocessing files (in SAFE format) if the subset operator is used first.

MERIS SAFE file → Idepix, all seems well.
MERIS SAFE file → subset → Idepix, the land mask seems poorly geolocated.

In the screenshot below there is a radiance band that Idepix has copied from the source file with the IDEPIX_LAND overlain, the lake is offset in the land mask. I’ve tried this in different images and with inland waters and coastal regions. As far as I can tell SNAP and the plugins are up to date.

The image in the example is ENV_ME_1_FRG____20110708T090010_20110708T091313_________________0783_104_194______DSI_R_NT____.SEN3.

Does anyone have any suggestions I could try?

Hello Nick,

I am trying to reproduce that behaviour and take the appropriate actions. I sent an email asking for more details.


Since the issue was solved via email exchange, I want to document it here for other users, in case they come across the same issue.

There is a tool in SNAP called “MERIS 4th to 3rd reprocessing adapter”.


This tool needs to be run before any subsequent processing of MERIS 4th reprocessing data.

If this tool is run, then the product subsetted and then IdePix applied, the land/water mask is located correctly (see below).

That solves our problem, many thanks!