Problem with terrain correction

Hi ABraun,
I am facing problem with terrain corrected data. I could not view the image after terrain correction this problem started only with my new work station(32GB RAM,16GHz processor,64 bit ,i7 8th Gen) . But the same image i could see in my old laptop(16GB RAM 4Ghz i5 processor).
I tried reinstalling the toolbox and doing the process but i could see the image after Deburst, speckle filter, calibration and all the other process. But after terrain correction display of the image blank but when cursor is moved X,Y ,lat long values are changing.

Here is the image

After terrain correction
Any problem with work station or i need to install anything or internal problem?
Kindly Please clarify

have you tried zooming in and wait a bit? Different gaphic cards handle these rasters differently (at least in my case).
You can also zoom to the original resolution grafik and wait for the image to build then zoom out. Doesn’t really solve your problem but, as apparently there are values in the raster, it is rather a matter of display.

Thanks for your reply. I am been trying all the possible ways. Tried without zoom in , but its not displaying even after left for an a day…

Any other way to resolve this display problem?
Thanks in advance…

DEM tile missing, most probably.

Hi @ABraun,
I also met this problem. I have tried different images but all got blank. Besides, I tried the image which I had succeeded in terrain correction, but now I can not view the image.

I have solved this problem after updating SNAP!
@nathiya you can try to update SNAP and do the terrain correction again.