Problems with selecting Masks as input in Graph Builder

I have problems with the graph builder.

  • In SNAP I did sen2cor on SE2, use the result in tab “Read” in the Graph builder and now I try to resample to 10 meter but cannot choose any band name.
  • I want to convert masks to bands by using Band Math and it works fine in SNAP but in the Graph builder > Edit Expression I cannot select Show masks. I can type the Expression “opaque_clouds_10m < 1 ? 0 : 1” but it gives the error “undefined symbol”

I am not very good at programming and tried to make a graph that I could edit for batch processing. I would like to find someone that had the same problem and solved it.


The user interface in the graph builder has some problems with the S2 data. Should be better with the next version.
Right now you can build the graph in SNAP and save the xml to a file. But don’t configure it now or only these parameters which cause no problem.
Afterwards you can edit the xml file and let it run from the command line with gpt on multiple products.
I’ve created a little sample and attached it here.

s2Graph.xml (1.7 KB)

It is not possible to select a band in the resampling operator in the Graph Builder at the moment. This will be fixed in the next version of SNAP, see SNAP-591.

I could reproduce your second problem and created the issue SNAP-611

Thank you marpet for the excellent suggestion, I will try your example.
Thank you Nicolas for letting me know these are issues and not my mistake.

Has this problem been solved?

I don’t believe so. I am still unable to select the opaque cloud mask in the graph builder.

Similar problem here: no means to (easily) keep the mask info after subsetting with snappy.