Problems with the Collocation Tool and georeference of Landsat 8

Only the latest fully updated version 8 is supported. Have you tried Reprojection of Landsat 8 into a coordinate reference system in SNAP?

I was using Snap 7 first, because of this Error in Version 8: SNAP new Version BIG Problem with data gaps!. But with Snap 8 it’s also the same issue. No i haven’t, i will try it later, thank you!

Sure i will test this later, thanks.

I checked this again on my side, used the mask as master and Landsat as slave and did not get this error message. I was able to collocate the mask with both L8 and L5.
Have you worked with BEAM DIMAP as output formats?

When I enter the mask as valid pixel expression, I can generate RGBs with the mask applied

Landsat 5

Landsat 8


Ok, i was able to solve it now using the following workflow:

  1. Downloaded 3 new Landsat 8 and two new Landsat 5 images from Earth Explorer, Collection 1 Level 1
  2. Resampled them all to size of their first band
  3. Made a subset from one of the resampled Landsat 8 images.
  4. Made a mask from this
  5. Opened band math and created a new band with the mask
  6. Made a band subset containing only the mask band, included the flag dataset
  7. Saved all as beam dimap.
  8. Used collocation tool: mask band product as master, saved as Beam Dimap

Now i can open Landsat 5 as Landsat 8 collocated products and use the mask in band math to go on with my calculations. I don’t know where the problem was, but now it works out! Thats’s great so far, thank you all really much for your help until here!!

The last question would be now: Is there a way to use graph builder and batch processing to get results like this?


So only the bands from the original product plus the mask in the new collocated product and not all the products collocated in one?
And this for all my 40 scenes, without having to collocate each individually? That would be a great plus, but if it’s not possible its’s also ok, i’m really satisfied until here now. Thanks again for your help, this forum is great! :slight_smile:

very good, thank you for sharing your solution.

Batch processing works in principle, but the tool does not dynamically adjust the output product name. Accordingly, while the stacks of each iteration are correctly opened in SNAP (separate), they are unluckily written into the same target product. This can be somehow handled with the “keep source product name” option, but I haven’t managed to use it correctly.
This has been reported here: Auto naming in Graph

You could, theoretically create a graph with two inputs, one is the mask and the other is the list of Landsat scenes and have all products opened in SNAP and then manually save them (right click > save as) under different names.

Sorry, i still don’t get how do do it, that that the “stacks of each iteration are correctly opened in SNAP (separate)”.

When i build a graph like this:

and run it directly in the graph tool, the Result looks like this:

So one Product, named _collocated, containing all the collocated Products in one.

When i load this graph in batch processing and run it with this settings:

the Result looks like this:

So all collocated products written in one again, but this time 39 times (the amount of my Scenes)

I don’t get what other settings i can choose to have them separated for each product?

you need two readers for the graph, one is the mask, the other a Landsat product.
When you open this graph in the batch-processing make sure that the mask is still selected as a master.

1 Like

Ah great, this worked. Thank you, again!

Now i have the next Problem…

The watermask in all collocated Products looks like this:

Normally it looks like this:

Anyone has an idea what happened here? It only happens when it’s saved directly in the Collocate Tool. If i don’t save it there it doesn’t happen. Also when i save it then, with right click in the product explorer, close snap and reopen it, the error doesn’t appear.

Actually i guess this is not the best solution for the problem, because when all products are named the same, and there is also no information about the slave product in the metadata anymore, it’s hard to find out which scene from which date you see. So considering this and the error i mentioned above a few minutes ago, the way to go for me now is: Collocate each scene individually and name it as the date without saving it and then saving each scene individually from the product explorer

Missed that, you’re right…

1 Like