Processing problem in Sen2cor

image After performing the sen2cor processing why I am getting this message.

Are you using the latest version of sen2cor (2.5.5)?

Have you somehow renamed the folder where the file was extracted?

You have to unzip the .zip and choose the .SAFE directory as an input. It is annoying but Sen2Cor expects the “S2?_MSIL1C*.SAFE” file name, otherwise it does not start the processing.

I am so much stressed with the same problem and even after your explanation I couldn’t follow the path. Can you please simplify the process for me ??


  1. Unzip/Inflate your .zip Sentinel-2 image
  2. Open SNAP and do not open any product
  3. Go to Optical > Thematic Land Processing > Sen2Cor
  4. In the I/O tab select the MTD_MSIL1C.xml file from the inflated .SAFE folder from Step 1.
  5. Adjust the parameters on the “Processing Parameters” as you wish.

As you can see form your screenshot, the product directory expected by Sen2Cor has the “following mask: S2?_MSIL1C*.SAFE”, so if the directory name does not match that convention, the process fails. Your input currently is “S2A_MSIL1C*.zip” so it does not match the regex

Thanks a lot, it worked. But I wasn’t able to do the same thing in Sentinal images with an ID like S2A_OPER_MSI_L1C_TL_MTI__20160721T153101_20160721T202439_A005642_T19TGN_N02_04_01 It only worked with the tiles with ID name starting with L1C like S2A_OPER_MSI_L1C_TL_MTI__20160721T153101_20160721T202439_A005642_T19TGN_N02_04_01 It says that the XML file couldnot be read.
Can you please tell me what’s happening.

the old Sentinel-2 products use the old naming convention. It was changed because the name of the files were too long and Windows wasn’t able to manage the long paths properly. If you have this kind of files you have to place directly on C:/ or in a path very short for being able to work properly.
I think that your problem is produced because when you unzip the products, there are files that cannot be unzipped in your output folder because tha path is very long, so finally SNAP cannot open the product because there are some missing files.