PSI: Error on first step on Matlab

Dear all ,
I am facing with following error on first step om Matlab:
StaMPS step 1;
Error using load
Unable to read file ‘…/’. No such file or directory.

Error in sb_load_initial (line 41)

Error in stamps (line 135)

Plaese help me to solve it.
And my data consist of 23 images, schould i divide them into two before stacking them on SNAP?

Thanks in advance!

1 Like

Please take a look at the following link which includes the whole step our colleagues are doing their best of sharing their knowledge

Thank you very much!
I followed this steps.
Now my problem is on Matlab, step 1, stamps (1,1). I got next error:

Error using load
Unable to read file ‘…/’. No such file or directory.

Error in sb_load_initial (line 41)

Error in stamps (line 135)

That is mean the change of directory to the right one should be done

I also had this error in Windows but not in Linux. Which system are you operating?


1 Like

the problem is solved after reinstalling the Matlab)

I work in windows environment, I installed Cygwin I ran the first script mt_prep_gamma_snap of stamps and I think it is good because all my pscands.ij files are not empty behave pscands.1.ij0. i use the trial windows matlab version, I got the following error message in running stamps(1,1).


Im trying to run Stamps Small baselines, from gamma pre-processing.

When I run Stamps (1,1) I get an error on sb_load_initial_gamma (line 146),

Index in position 1 exceeds array bounds (must not exceed 2).

Error in sb_load_initial_gamma (line 146)
bl=mean(sort_x(1:n_pc,:)); % bottom left corner!

Has this relation to the number of ps? or and dem error?, I checked the dem.rdc and I see no gaps, and the number of lines and width is correct.

If someone can illuminate the error I would appreciate it.


did you find any solution for this problem? Thanks

There was an error in the code where an apostrophe was missing. So instead of generating a column it was reading a line. I reported it to the developers. So there may be an update or You could just add it.
For more info check the stamps GitHub

1 Like

Thanks chanitacr . I found the error in the code on this link:


I’m having the same issue, i’ve reinstalled MATLAB twice but the issue hasn’t gone away. What version of matlab are you using, maybe it’s a version issue.

I’m using R2019a in ubuntu.

I had the same problem, I solved running matlab using csh


have you solved it?

Dear all,
i managed to export the snap to gamma format and do the mt_prep_gamma
Finally, when i start with my stamps processing in matlab. I get the following error:
when i run the first step of stamps:

Index in position 2 exceeds array bounds.

Error in ps_load_initial_gamma (line 108)

Error in stamps (line 263)

Please do help if anyone knows what to be done with this.
@thho @ABraun Can you help me with this ?

Hi @Narayanee,
when you are using StaMPS v4.x use mt_prep_snap, not the gamma script, this was done in version 3 but is not necessary any more, since snap has now it’s own preparation script.

Thank you so much. @thho
but i still continue to get the same error. So i tried looking into the files of patch 1 created after running mt_prep_snap.
I opened the ps_load_initial_gamma.m file to look at the code. this line
ijname=[’./pscands.1.ij’]; has the variable initiative. This variable is further used as ij which is shown as error in my previous post.
so i tried opening this file and there was no data in it which i found it strange. Is it the same way for everyone or am i doing some mistake?

Most of the time, when I did had this error or people here reporting it, is because of a wrong preprocessed interferogram in SNAP. Before exporting, I always suggest to double check all interferograms. This is what I would do first, hope that helps a bit.

Thank you. I had problem with my interferogram as you said. Thank you for your insight.

With regards

1 Like