PSI: Error on first step on Matlab

Hello, I apologize for this interruption, but I had difficult special circumstances related to my health and my family.I did it again, but I still get an error, please help. God bless you

Your file path has ~/home/<username>/Documents/.... This indicates you are not familiar with the linux command-line. I have taught workshop practical sessions on remote sensing, and quickly found that we saved a lot of time and frustration if we spent the first couple sessions introducing linux concepts. There are many excellent (as well as some that are less than useless) resources to help user become proficient in linux. Once you find a good introduction to the linux command line, it should not take long for you to understand why your file path doesn’t work, and in the process you will learn other things that will be helpful (starting with where to look when you have a question). One good starting point is

I have got this error while checking if matlab has stamps well-configured

I have installed all dependencies and packages exactly how the tutorials stated, I also had a "/usr/lib/x86_64-linux-gnu/ version `GLIBCXX_3.4.26’ not found " error that wouldn’t enable launching matlab and I fixed it by running

sudo apt-get dist-upgrade

but I can't seem to link matlab to stamps

have you modified and sourced the StaMPS_config file as described here: StaMPS/ · master · Matthias Schlögl / gis-blog · GitLab

yes. Here’re the contents of StaMPS_CONFIG.bash file

The desktop configuration was not saved successfully 
> help stamps 
An error was encountered while saving the command history /home/shadi.matlab/R2022b/ (Permission denied)

This error often occurs when a user has run sudo matlab. You should check ownership and permission in your ~/.matlab tree.

looks fine, now add these to the Path:
source /home/shadi/StaMPS/StaMPS_CONFIG.bash

This makes all commands available for the open command window. Once you close it, you have to run the source command again.

1 Like

That’s weird, I cannot change permissions

Great, I have changed the ownership and the problem is partially solved,

Update, ~/.matlab all subfolders’ permissions were changed as well
but i am still faced with this desktop configuration error (if it’s critical)

I think Matlab configuration uses some other locations. Those should be documented on the Mathworks site. Some locations may depend on the desktop environment. A reinstall is generally easier than tracking down all the damaged permissions.

If that is what may have been causing the crash problem, must I rename those libraries during support installation?

or should I exactly follow that tutorial

where it says :

You should follow the suggestion made by the installer. The “solution” relies on the state of ubuntu-toolchain-r PPA at a particular point in time – there is no guarantee that it will continue to work with
future versions of Matlab and Ubuntu.

If the installer doesn’t work, the Mathworks forums are more likely to have a robust solution, and the solution will be visible to all Matlab users.

Please follow this instruction. it works for me in ubuntu 22.04

sudo gedit /etc/apt/sources.list

paste deb [arch=amd64] Index of /ubuntu focal main universe in line 45

than follow ABraun explanations

The whole crash problem was eventually solved after increasing the number of PATCHES (even though that Failed to load module “canberra-gtk-module” error still appears, which was rendered unsolvable yet un-harmful bug with most Matlab versions according to Mathworks community). Looks like I over-estimated the hardware capabilities of my computer. Regardless, I am still so grateful for your various attempts to help solve my problem.

please I added:

deb [arch=amd64] Index of /ubuntu focal main universe

to /etc/apt/sources.list

and ran: apt update; apt install g+±7

click@click:~ sudo nano /etc/apt/sources.list click@click:~ apt update; apt install g+±7
E: Malformed line 1 in source list /etc/apt/sources.list (type)
E: The list of sources could not be read.
E: Malformed line 1 in source list /etc/apt/sources.list (type)
E: The list of sources could not be read.
but I can not install g+±7
please help

You have C++ style comment “//“ prefix, but you need to use “#” for this file.

Thank you. Finally, the problem was solved and it was successfully executed mt_prep_snap ,

but when I opened Matlab, it did not find stamps,

although before I install GCC-7 and succeed in running mt_prep_snap it was found

I have installed stamps exactly As mentioned

why I do not find stamps in matlab…please help
thank you in advance

Set the stamps path to the Matlab,

What could be causing this error? I don’t quite understand the error message