PSI using SNAP-STaMPS workflow in Windows Subsystem for Linux (WSL)

why is there a ~

I think this should be an empty space.

1 Like

this ~ was in the tutorial too. i think i missed the space… so i tried it again with the space in it, but is responds in the same way as before

1 Like

which tutorial?

the tutorial of @amirolinxa, that stands in this page

my bad, i can see now where is the mistake. the file path wasn’t the right one. @ABraun thank you for helping me

1 Like

Very good! These things can be confusing indeed :wink:

1 Like

everytime I try to go further with the example, I find something wrong… I already did the mt_prep_snap and it seems to go well. but I had to leave the work and turned off the pc without going do matlab. Now I am to the directory of INSAR_master_data and i run matlab. but when i write "stamps(1,8) in the matlab commands it says: Undefined function or variable ‘stamps’. maybe because i have to re-run the mt_prep_snap and go to matlab right after that, without any interruption?

you should not close the linux terminal and if you close it you have to redo the sourcing of stamps config file again.


ok, of course there is another problem… I think i have to add any plug ins for matlab because this error is occuring:

reinstall matlab and be sure that you checked the following toolbars

Parallel Computing Toolbox (DM)
Image Processing Toolbox (IP)
Signal Processing Toolbox (SG)
Statistics and Machine Learning Toolbox (ST)


Hello again, i’m facing a new problem , this time when ploting for the results.

PS. I did some research for other people having the same problem, it seems I had to Take a bigger Radius for the TS selection

To be honest, I havent faced with such a problem so far. have you tried with smaller radious.

actually, it worked with a bigger radius. I think it needed more points to work

Still, we are mixing up issues in this thread.
The issue you mentioned is it not anymore snap-stamps in WSL, but the exporting of variables to use the TS visualiser, right?

I say this just for keeping a sort of order in the threads, otherwise is all together making difficult to follow them all.

1 Like

sorry, I am new in this forum, I got things mixed up. thank you for the clarity

yes, the problem i’m talking about is with matlab comands to export the variables in order to use them in the TS visualiser.


I want to share my “experience” in StaMPS with Linux-WSL + Windows.

Thanks to @amirolinxa I could install and do some process in Ubuntu WSL.

I had a lot of problem with mt_prep_snap command but @mdelgado solved it suggesting to use an older version of gcc e g++.

After having compute mt_prep_snap, it is the time of using Matlab.

I had problem linked to matlab installation in Ubuntu, so as @amirolinxa suggested in his guide:

“In case you couldn’t figure it out how to install it, it is also possible to just move the prepared package by STaMPS to windows and also copy and paste all the files in stamps>MATLAB folder to the same folder and continue the rest of the steps in windows”

Few steps are needed to let stamps work well in Matlab for Windows:

  1. open matlab (in Windows)

  2. oldpath = path;

path(oldpath,‘c:\matlab’), where matlab is the folder included in Stamps

  1. copy in Windows the folder given by “mt_prep_snap”


  1. go in the “INSAR_master_data” folder and change all the path of:
  • rsc




  • …… all the files with Linux path

with your Windows path

  1. if you did not already install “triangle”, install it following @ttolhurst advices

  2. change movefile with copyfile in stamps.mat (around line 462) - if stamps(5,5) gives you some issues

  3. run “stamps(1,8)” in this folder

It works for me.

As I already said, I am new in Stamps.



Hi, i am trying to run the command stamps(1,8) in matlab and this problem occours:

what does it mean that array indices mys be positive

I want to specify that i am working with CSK file ( CosmoSkyMed products). I did the pre-process in snap, following the right procedure

Anyway I managed to solve the problem. Finally i came to some results. but to be honest, I was expecting something else. I did the same process with the Sentinel 1 data ( using only 10 images) and I had more points over the territory, as the figure below:

As you can see i do have points all over the territory.

But i did the same process with 28 images (covering about 5 years) of CSK ( COSMO SkyMed products) and the points aren’t very much in the rural area, but are concentrated only in the urban one. Morover, they doesn’t even cover all urban areas. some big parts are left without deformation points. How is that possible?
(Unfortunately I can’t put here the picture of the stamps visualizer)