PSI using SNAP-STaMPS workflow in Windows Subsystem for Linux (WSL)

Thanks again.
No, I think the installation is correct because I can open Matlab in Linux terminal.

However the main problem is:

“Segmentation fault (core dumped)”

check the following link pls.

the guy had the same problem. he could finally solve it by reinstallation of linux. but I am sure there should be another way.

another hint. try to give a full permission to all the folders that you are working in linux.

PSI using SNAP_STAMPS tutorial 2_PSI process.pdf (973.9 KB)
There was a small error in second instruction-step1-7

1 Like

Thank you.

I checked the permission and all my folders have full permission (R-W-X).
It is really weird I cannot find out the problem.

Looking at the mt_prep_snap, the next command after the “Processing 1 patches” line is:

matlab -nojvm -nosplash -nodisplay < $STAMPS/matlab/ps_parms_initial.m > ps_parms_initial.log

so the Segmentation fault seems to come from Matlab.
What happens when you run matab -nojvm -nodisplay?
What is in ps_parms_initial.log?

1 Like

when I try to run matlab -nojvm -nodisplay, this happen (so Matlab works):

In ps_parm_initial.log there is the following:

                        < M A T L A B (R) >
              Copyright 1984-2018 The MathWorks, Inc.
               R2018a ( 64-bit (glnxa64)
                         February 23, 2018

For online documentation, see
For product information, visit


It might not be related but as I suggested before, try to install a light desktop. cuz in that case more libraries and system tools will be installed and your ubuntu become more similar to the standard version of linux

Thanks a lot

What do you mean for light desktop? like Xlaunch? I followed your guide and I installed “lxde” and “VcXsrv Windows X Server”

the same thing. so in that case I dont know really what can be a source of errores

1 Like


Do you think that installing linux in a virtual machine could be easier than Ubuntu WSL?

you welcome.I dont think so, I had the similar problems with original linux. these are open source softwares and from system to system you have to make some configuration. it took me two months to install another opensource software in original linux. there is guy that did like 12 attempt to install it and yet he coulndt. he put all the videos on youtube. :slight_smile: . just give me your email. i will send you a package ready fro stamps analysis. if the problem happens again, you will be sure that it is not related to snap part or data

1 Like

Use an older gcc version to compile the stamps/src folder.
This solves it.
You could use the same gcc version provided with Ubuntu 18.04. This has no problems

You can install Ubuntu 18.04 (WSL) from the Windows “store”. If you have ample RAM, a VM install should give considerably better performance. Many people are
running SNAP in Ubuntu 18.04, so there is a good chance that someone will have a solution to any problems you encounter.

Thank you very much.
I will try to install gcc-4.5 version on Ubuntu 20.4.
I will tell you if it works.


Let me know. I am curious about the installation of older gcc version in ubuntu 20.04
I know that if you use ubuntu 18.04 this problem that not happens.

gcc-4.8 should be ok as well. Newer not.

1 Like

Thank you very much. It totally works.
I installed gcc-7 version.

Thank you again

1 Like

For people with this problem:
install an older version of gcc (if you have installed ubuntu 20.04).

Good to see that I was right and you got your problem solved.

now the question would be:
can you explain how you install it?
just : sudo apt-get install gcc-7 ??

or something else?

You have to do:

  • gcc -v --> to check which version of gcc
  • sudo apt -y install gcc-7 g+±7
  • sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-7 7
    sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g+±7 7
    –> to change the version

(check to have installed also build-essential)


Hi. I tried to follow every step you told, but I seem to have a problem when I try to run StaMPS. This is what I get after the command: mt_prep_snap…